• Nobody/Anonymous

    first, i try to convert 30mb wav to mpeg. Aanndd ..

    1. if you resize window - system lockup.
    2. if you will try to run others apps while ffmpeg is working - system lockup
    3. if you press [q] (as said in ffmpeg) -nothink happenes, if press ctrl+c ffmpeg exit, but after this - system lockup.

    Well, next, i try just to convert and test 30mb wav.

    12.work:FroggerNG> cd work:tests/ffmpeg-0.4.9-pre1/
    12.work:tests/ffmpeg-0.4.9-pre1> ffmpeg_wos -i 02_AudioN_02_56_02.wav 1.mpg
    ffmpeg version 0.4.9-pre1, build 4718, Copyright (c) 2000-2004 Fabrice Bellard
    built on Aug 7 2005 22:23:23, gcc: 2.95.2 19991024 (release)
    Input #0, wav, from '02_AudioN_02_56_02.wav':
    Duration: 00:00:00.0, bitrate: 2147483 kb/s
    Stream #0.0: Audio: pcm_s16le, 44100 Hz, stereo, 1411 kb/s
    Output #0, mpeg, to '1.mpg':
    Stream #0.0: Audio: mp2, 44100 Hz, stereo, 64 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Press [q] to stop encoding
    size= 53kB time=64.1 bitrate= 64.4kbits/s

    work take a 30 seconds equal. (and after programm exit if i try to resize window, or just run other progs: of course :), system lockup. but output file was create and is worked. By default codec is sucked (demuxmpeg). And can't play normally at amigaos (for me, i try songplayer, amigaamp, frogger, it works, but with glitches but file is good, becouse i test in on winxp in internal player of windows commander)

    Well, next, i try -vcodec mpeg4 option. The same result. Demuxmpeg agayn. Ok, i try -acodec mp3, after some encoding - programm halt :) Sad.  Ok, trying more. Take it divx on 30mb, and try.

    12.work:tests/ffmpeg-0.4.9-pre1> ffmpeg_wos -i story_of_pacman_1980.avi story_of_pacman_1980.avi 1.mpg
    ffmpeg version 0.4.9-pre1, build 4718, Copyright (c) 2000-2004 Fabrice Bellard
    built on Aug 7 2005 22:23:23, gcc: 2.95.2 19991024 (release)
    Input #0, avi, from 'story_of_pacman_1980.avi':
    Duration: 00:04:11.2, bitrate: 938 kb/s
    Stream #0.0: Video: msmpeg4, 512x286, 25.00 fps
    Stream #0.1: Audio: mp3, 44100 Hz, stereo, 111 kb/s

    Params of story_of_pacman_1980.avi

    Video Stream:

    Frame size : 512x286, 25.000fps, (40000us)
    Lenght : 6282 Frames (4:11.28)
    Decompressor : DivX MPEG-4 (Low-Motion)
    Number ok key frames : 63

    Audio Stream:
    Sampling Rate : 44100
    Channels : 2 (stereo)
    Compression : Fraunhofer IIS MPEG Layer-3 Codec
    Lenght : 3511300 samples (4:11.29)

    So, time for decoding this file to mpeg by default option ( i mean not any keys, just amiga shell:> ffmpeg -i 1.avi 1.mpg) on my bppc x 266 mhz / 060 x 66 mhz - 20 min. 28 sec. No so slow anyway as on my 3ghz PC. Slow, but not so. For 266 mhz is fast :)

    Well, try to play it with frogger, and yes ! it work ! :) And result file have 6.3 mb of lenght !

    But result:

    Synchro - is broken at trash. Really. Video by default looks pretty nice. Plays fast, but synchro with sound .. And sound end little early as end video. But some options maybe ..

    So, result ! Programm work. But VERY sucked bugz like lookups. Strange bug with mp3 encoding. Not any help by -h --h --help -? --? ! And in file i do not found plain text help info. And strange situation with synchro. But, if you can/want - test it more and write here !

    • Diego Casorran

      Diego Casorran - 2005-10-22

      I've forwarded this post to DMX, just wait...

      IIRC he used StormC to build ffmpeg for WarpOS which could be the cause for some issue, like ^C signals...

      Thank you for the report.

      btw, we will appreciate if those anon post are atleast signed with a nick...

    • Nobody/Anonymous

      btw, comments and posts from forum just do not work for me .. for me only, or it is broken ? i must use project page for this postings ..

      and what about programm , as in the case with lamewos, problem in stack size. 10.000 its too low, and best choice 100.000 (i think best way is write some words about it in amiga specific readme :) ).

    • Nobody/Anonymous

      Make sure your stack is set to at least 1.5MB, on a minimal setup and no other WOS programs/patches running in the background.



Log in to post a comment.