make problem: gtk-config not found

Help
2001-05-29
2001-06-01
  • Amund Sjaavaag

    Amund Sjaavaag - 2001-05-29

    I tried to install althea under Mandrake 8:
    # make
    g++ -Wall -c Althea.cpp `gtk-config --cflags`
    /bin/sh: gtk-config: command not found
    In file included from Althea.cpp:8:
    Althea.h:9:21: gtk/gtk.h: No such file or directory
    make: *** [Althea.o] Error 1

    I can't find the gtk-config command anywhere on my harddisk. I tried to install all the gtk packes i could find:
    # rpm -qa | grep gtk
    rep-gtk-gnome-0.15-2mdk
    gtkdialogs-1.0-3mdk
    gtkzip-0.5.1-10mdk
    gtkhtml-0.8.3-2mdk
    gtk+licq-0.50.1-3mdk
    libgtk+1.2-1.2.10-1mdk
    libgtkhtml7-0.8.3-2mdk
    gtk+mdk-0.1.5-5mdk
    libgtkglarea5-1.2.2-7mdk
    libgtkxmhtml1-1.2.13-1mdk
    libgtkmm1.2-1.2.5-3mdk
    gtk-engines-0.12-1mdk
    gtktalog-0.15.1-1mdk
    rep-gtk-0.15-2mdk
    pygtk-0.6.7-1mdk
    pygtk-libglade-0.6.7-1mdk
    pygtk-glarea-0.6.7-1mdk
    gtk+licq-base-0.50.1-3mdk

     
    • Daler

      Daler - 2001-05-29

      gtk-config comes with the devel packages for gtk+ in Mandrake I believe.  So try installing gtk+mdk-devel and libgtk+1.2-devel.  That should get you going (I'm basing my theory on the fact that the RedHat rpm called gtk+-devel includes /usr/bin/gtk-config)

       
    • Amund Sjaavaag

      Amund Sjaavaag - 2001-05-30

      Thanks for the help. The gtk-config command is now working. Here is a new make problem:

      # make
      g++ -Wall -c Althea.cpp `gtk-config --cflags`
      g++ -Wall -c main_window.cpp `gtk-config --cflags`
      In file included from callbacks.h:21,
                       from main_window.h:17,
                       from main_window.cpp:6:
      errors.h:74: `const' can only be specified for objects and functions
      make: *** [main_window.o] Error 1

       
      • Daler

        Daler - 2001-05-30

        Ok thats really funky.  What version of althea are you trying to compile?  I looked at the latest CVS source for errors.h and errors.h in althea-0.5.1 and neither of them have a 'const' in them.  And also, what is the version of g++? 

         
        • Amund Sjaavaag

          Amund Sjaavaag - 2001-05-31

          I tried this version, but i guess it is to old:
          http://ftp1.sourceforge.net/althea/althea.tgz
          I downloaded althea-0.5.1.tgz and the make succeeded, but it seems like i have version 0.5.0.
          It is possible to read mails in the inbox, but i don't see any other folders. I guess i have to wait for newer releases, and i may use Mozilla untill then.

          By the way, here is  the versjons of g++:

          $ g++ -v
          Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux/2.96/specs
          gcc version 2.96 20000731 (Linux-Mandrake 8.1 2.96-0.53mdk)

          And the version of the mailserver:
          IMAP4 server (InterMail vM.4.01.03.23 201-229-121-123-20010418)

           
          • Daler

            Daler - 2001-06-01

            Yes you should have version 0.5.1 if that is the tar ball you downloaded.  In the haste to get 0.5.1 out the door, we forgot to change the version number.  Doh!

            To get to the the whole reading messages in different folders, I think the solution to this was to run pine 1 time and let it setup all the folders in your home directory.  Then althea should read everything in correctly, assuming that your configuration points to the correct place for your mail.

            I will say that being able to move things between folders and all that kind of "Folder Management " stuff is not yet functional (we have the network functions written, thanks to Ethan, but the GUI is not hooked up). 

             

Log in to post a comment.