Hi Walker!

Thank you very much! That was it, I didn't use envy24control for setting the right sample rate...!!! I though this app wasn't needed!

Actually my card was always running @48Khz, even when I start jack @44.1Khz, and so the sound wasn't good...

Thanks to you, now everything work as expected (and I even discover I can monitor the input too, which can be useful :)

Again, thank you for your answers, they were very helpfull for me!!

Pilo.


Hey Pilo,

I do everything from the gui, so while we /should/ be having the same
results that doesn't mean we /will/, you know?  I use qjackctl for jack
and envy24control (from alsa-tools) for setting the card params.  Just
another random thing that might inexplicably solve it (happens all the
time.)

Apparently, qjackctl is doing this for me:

/usr/bin/jackd -R -P27 -p128 -dalsa -r48000 -p256 -n4 -D -Chw:M2496
-Phw:M2496

-R is for realtime, -P sets priority, -p is port max;
alsa driver options -p period -n #periods -D duplex, then card names...

I can't see anything that should be making mine do the sample rate
right and yours not...

Doing my usual shotgun debugging I'd try

jackd -d alsa -r 44100 -C hw:M2496 -P hw:M2496

with wherever yours is at for M2496.

Seriously I'm just guessing though.

Also, are you sure you're not resampling during export in ardour?  I
made that mistake once, but I'd hope the default is what the project
is in...

Good luck,
Walker

On Tue, 23 Feb 2010 10:24:59 +0100
Pierre-Laurent CHAMBERT <pierrelaurent.chambert@gmail.com> wrote:

> Hi Walker,
>
> Thanks for your answer!
>
> Maybe I'm doing something wrong?
> I run jack using :
> jackd -d alsa -r 44100
>
> then
>
> pilo@pilo:~/schematic$ cat /proc/asound/card0/pcm0p/sub0/hw_params
> access: MMAP_INTERLEAVED
> format: S32_LE
> subformat: STD
> channels: 10
> rate: 44100 (44100/1)
> (...)
>
> So when I run ardour, it uses 44100Hz for project sample rate. But,
> most of the time, alsa seems to assume that the output freq is
> 44.1Khz, but "requested" freq is 48Khz, and so resample the sound
> (which is then faster and higher in pitch as it would be).
>
> Sometimes it works (for example when jack is the first one to use the
> sound card). The same trouble when I use a software which use oss
> emulation....
>
> I really don't know what to do, I would prefer that alsa does no
> resampling at all!
> Last time a friend send me drum tracks @44.1Khz, I play bass on
> those, and when I sent them back to him he told me "ouaw! you are
> tuned very low!", and I was not, that's how I discover there was a
> trouble with SR.
>
> I try to play with .asounrc, by forcing Sample rate, but this doesn't
> work. And I wonder what would happen if I use the spdif in and out
> with this frequency trouble....
>
> Anyway, thank you!
>
> Pilo.
>
>
>
> Hey,
> I'm using that card (with jack and ardour even), but I'm not an
> alsa-expert. Just guessing, but do you have jack set to run at 44100?
> Jack seems to override whatever other ways you've set the sample rate.
>
> Bigger problems with that card and alsa seem to be that you need to
> set .asoundrc for it to work with certain apps, and even then it seems
> to have problems if you're running pulse to alsa to it, or even
> without it sometimes crashes. Not with any jack app, of course, just
> other apps, I mean.
>
> Walker
>
> On Sun, 21 Feb 2010 12:02:31 +0100
> Pierre-Laurent CHAMBERT <pierrelaurent.chambert@gmail.com> wrote:
>
> > Hi everyone!
> >
> > I'm using an audiophile 2496 with alsa to do some pro audio working,
> > mainly with ardour and jack.
> > Unfortunately, I have a big problem with alsa : (automatic)
> > resampling!
> >
> > Most of the time I can't work on 44100Hz project, even if I run
> > jackd with a 44.1Khz freq, the card internal clock is at 44.1Khz
> > (accord to /proc/asound info), but the sound is resampled just like
> > if the card run @ 48Khz... and so the sound is faster and higher
> > (impossible to work with). I don't understand how the resampling
> > works in alsa, is there anyway to turn it off?
> > When working at 48Khz it seems to always be fine...
> > It is a real issue, and I can't really find useful info about it.
> >
> > By the way, in alsa 1.0.22 driver, ice1712 module (used for
> > Audiophile 2496) is missing! (the source code is here, but no module
> > is not compiled, whatever options is turned on during compiling).
> >
> > Thank you very much!
> >
> > Pilo