Hello all and TIA

I've tried as much as what I've been able to find info on...

I'm using FC1
uname -r
2.4.22-1.2115.nptlsmp

I followed these directions:
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Intel&card=i820&chip=i820&module=intel8x0

No errors on compilation or anything. I ran /sbin/alsaconf. Levels were set up using alsamixer, and also kmix in KDE, and I tried it in Gnome as well (sound icon that shows up in bottom right tray).

Interestingly enough, if I do /etc/init.d/alsaound restart in KDE, I hear a popping as if the drivers are getting loaded. However, I think herein lies the clue: when I boot up KDE, I get the error:
Sound server informational message:
Error while initializing the sound driver:
can't start sound i/o
The sound server will continue, using the null output device.

I also get that same error (above) if in Gnome I start noatun.

Here's some outputs that will hopefully help:

***************************************************************
[ron@localhost ron]$ /sbin/lsmod
Module                  Size  Used by    Tainted: PF
ppdev                   6956   0 (autoclean)
joydev                  7424   0 (autoclean)
vfat                   13228   0 (autoclean)
fat                    40216   0 (autoclean) [vfat]
snd-mixer-oss          16888   1 (autoclean)
snd-intel8x0           25452   1 (autoclean)
snd-ac97-codec         68784   0 (autoclean) [snd-intel8x0]
snd-pcm                89504   0 (autoclean) [snd-intel8x0]
snd-timer              21444   0 (autoclean) [snd-pcm]
snd-mpu401-uart         5632   0 (autoclean) [snd-intel8x0]
snd-rawmidi            19936   0 (autoclean) [snd-mpu401-uart]
snd-seq-device          6384   0 (autoclean) [snd-rawmidi]
snd                    51332   0 (autoclean) [snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
gameport                3508   0 (autoclean) [snd-intel8x0]
snd-page-alloc          8172   0 (autoclean) [snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
vmnet                  25936   6
vmmon                  42141   0
parport_pc             19204   1 (autoclean)
lp                      9252   0 (autoclean)
parport                39072   1 (autoclean) [ppdev parport_pc lp]
autofs                 13780   0 (autoclean) (unused)
ns83820                16432   1
floppy                 58908   0 (autoclean)
sg                     37580   0 (autoclean)
sr_mod                 18200   0 (autoclean)
microcode               5024   0 (autoclean)
ide-scsi               12400   0
ide-cd                 35904   0
cdrom                  34208   0 [sr_mod ide-cd]
evdev                   5984   0 (unused)
wacom                   7996   0 (unused)
audio                  47996   0
soundcore               7044   2 [snd audio]
keybdev                 2976   0 (unused)
hid                    24740   0 (unused)
ehci-hcd               20776   0 (unused)
usb-uhci               27436   0 (unused)
usbcore                82912   1 [wacom audio hid ehci-hcd usb-uhci]
mousedev                5688   1 (autoclean)
input                   6208   0 (autoclean) [joydev evdev wacom keybdev hid mousedev]
ext3                   74148   2
jbd                    56624   2 [ext3]
raid1                  15980   1
raid0                   3848   2
ata_piix                3908   6
libata                 28516   0 [ata_piix]
sd_mod                 13708  12
scsi_mod              111496   5 [sg sr_mod ide-scsi ata_piix libata sd_mod]

**************************************************************
here's my /etc/modules.conf

alias eth0 ns83820
alias scsi_hostadapter ata_piix
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
#alias sound-slot-0 i810_audio
#post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
#pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

**************************************************************

/sbin/lspci
00:00.0 Host bridge: Intel Corp. 82875P Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corp. 82875P Processor to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 500] (rev a3)
02:0a.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
02:0c.0 Ethernet controller: National Semiconductor Corporation DP83820 10/100/1000 Ethernet Controller

TIA!!!