Hi ,

I am replying to this as I had originally posted the issue in the link provided by Pablo. 

The issue with mine was that it was plugged into a laptop usb port which was on an internal usb hub and hence couldn't handle duplex. I applied the patch on the 3.0.13 kernel and it  worked beautifully, but is now causing other problems (my internal laptop web cam that is also plugged in via another internal usb hub does not work. It works with the kernel without the patch).  I will be testing this more in detail and filing bug reports if required.

My device is a usb 1.1 device and it had problems in duplex mode. I have another usb 1.1. card which worked just fine. Alexander mentions that his device works just fine in usb 1.1 mode and has problems in usb 2 mode, so I don't think that it is not the same thing as my issue. 

Alexander, just curious, are you plugging your card into a hub or directly into your PCs usb ports?


On Fri, Nov 25, 2011 at 11:45 PM, Pablo Fernandez <pablo.fbus@gmail.com> wrote:p 

On Fri, Nov 25, 2011 at 3:14 PM, alexander <axeldenstore@gmail.com> wrote:
On 11/19/2011 10:13 PM, Daniel Mack wrote:

On Nov 19, 2011 11:22 AM, "alexander" <axeldenstore@gmail.com> wrote:
> I recently bought a sound devices usbpre2 wich is both usb1.1 and usb2
> class compliant.. It works very well as a usb1 device but not as usb2..
> with jackd I can get it to run as record only, but not playback only or
> duplex..

Could this be a similar issue?

BTW, I have just read in lkml that Thomas Poussevin's patch is included in linux 3.2 rc3. :)

Cheers, Pablo


All the data continuously generated in your IT infrastructure
contains a definitive record of customers, application performance,
security threats, fraudulent activity, and more. Splunk takes this
data and makes sense of it. IT sense. And common sense.
Alsa-user mailing list