I noticed that error messages

hda-intel: spurious response ....
hda-intel: azx_get_response timeout, switching to polling mode:
...
hda_intel: azx_get_response timeout, switching to single_cmd mode

are present in dmesg only when Intel integrated graphic card is used. The system has two GPUs (Intel + ATI dedicated).
If ATI card is selected at boot (using vga_switcheroo) no such messages are displayed.

Is there any logical explanation to this behavior?
Thanks and regards,

Tommaso

2011/7/27 Tommaso Falchi Delitala <volalto86@gmail.com>
Hi everybody,

I think there is something wrong with the intel-hda model autoprobing
on my Acer TimelineX 4820TG.

The chip is recognized as:
"hda_codec: ALC271X: BIOS auto-probing",
but Pcwizard under Windows 7 reports it as Realtek ALC-269. Other info
I found on the Internet seem to confirm 269 is the right codec.

Can anybody confirm the correct model onboard the Acer 4820TG?

Dmesg is populated with:
hda-intel: spurious response 0x0:0x0, last cmd=0x270d80
[...]
hda-intel: azx_get_response timeout, switching to polling mode: last
cmd=0x00270e02
[...]
hda_intel: azx_get_response timeout, switching to single_cmd mode:
last cmd=0x00170503
azx_single_send_cmd: 177 callbacks suppressed

I guess these erros result from wrong model autoprobing.
Audio works anyway, but occasionally lags and shows major problems
after enabling powersave features.

I tried to force audio model with:
options snd-hda-intel model=laptop-amic probe_mask=1, or
options snd-hda-intel model=acer
but it doesn't work.

Is there a real problem in the codec model auto-probing?
Should I file a kernel bug or am I missing something in the configuration?.

Thank you for your help,
Best Regards,

Tommaso

-----Other useful info:
OS: Arch Linux, kernel 3.0.0 (same with 2.6.39)

Driver version:     1.0.24
Library version:    1.0.24.1

Soundcards recognised by ALSA

0 [Intel]: HDA-Intel - HDA Intel
  HDA Intel at 0xdc500000 irq 44
 1 [Generic]: HDA-Intel - HD-Audio Generic
  HD-Audio Generic at 0xdc420000 irq 45

PCI Soundcards installed in the system

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset
High Definition Audio (rev 05)
01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio
[Mobility Radeon HD 5000 Series] (rev ff)

00:1b.0 0403: 8086:3b56 (rev 05)
       Subsystem: 1025:0359
--
01:00.1 0403: 1002:aa68 (rev ff) (prog-if ff)
       !!! Unknown header type 7f