Hello Philipp,

After reading your useful message, all I did was run asoundconf and then fiddle with the switches of Kmix. I don't know if asoundconf did anything but I'm fairly certain that the problem was one or more of the Kmix switches on or off. [The help for the Kmix switches never seems to explain enough to me. In the past, after fooling around with so many other things and files, I finally solved a no-sound problem by turning some switch on or off.] Now I have sound and am happy again. 

Stan    :-D

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Without music life would be a mistake.  

 - Friedrich Wilhelm Nietzsche, philosopher (1844-1900)


Music is another planet.

 - Alphonse Daudet (1840-1897; French novelist)

_______________________________________________
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user
 
Hey Stan,
have you tried to install the alsa-base and alsa-utils packages from your distribution, before you tried to compile those by yourself? Sidux uses the original Debian-repositories afair, so "sudo aptitude install alsa-base alsa-utils" might help you with your problem.
Asoundconf, aplay, alsamixer, etc. sometimes disappear when you compile alsa by hand while your distro already had it installed. You probably could solve this by reinstalling alsa as mentioned above.
Did you try to run those commands as root? Perhaps they only got moved to /usr/sbin/
If all this does not show any success, then try to run "alsamixer" and play around with the switches.
I hope, I was able to help you,
Philipp