Last year, when I found the distro sidux, I had no sound after installing sidux. It took some study, effort and requests for help to get sound working. I'm no expert in Linux but I got sound working in sidux.

I still have the same computer that had sidux as OS. But due to a recent problem with my current and new ISP having a problem dealing with apt-get, I lost the old version of sidux and was forced to install the latest version of sidux. I again have no sound. I downloaded and installed the various alsa packages (driver, lib, and utils, all being version 1.0.19) but I must have done something wrong over the past few days while I continued to try to figure out why sound was absent even though I knew the hardware was OK.

I've checked the usual things, such as looking at what's muted in kmix and making sure that sound is enabled in K > Control Ctr > Sound & Multimedia > Sound System. I ran alsaconf which didn't help. [**Incidentally, alsaconf which did show my sound electronics a few days ago, now doesn't even show my Intel integrated sound electronics!** I thought the bios had been changed but see that sound is enabled and PnP is too.] [alsaconf has also vanished from the K menu.]

/etc/modprobe.d/sound  is also now missing. How is that restored?

Here's some command outputs that might help you help me. If you need any other outputs, please tell me.

$ lsmod | grep snd
snd_intel8x0 28856 1
snd_ac97_codec 102144 1 snd_intel8x0
ac97_bus 1532 1 snd_ac97_codec
snd_pcm_oss 37696 0
snd_mixer_oss 14620 1 snd_pcm_oss
snd_pcm 73888 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_oss 31296 0
snd_seq_midi_event 6876 1 snd_seq_oss
snd_seq 50288 4 snd_seq_oss,snd_seq_midi_event
snd_timer 20580 2 snd_pcm,snd_seq
snd_seq_device 7016 2 snd_seq_oss,snd_seq
snd 56420 11 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
soundcore 7136 1 snd
snd_page_alloc 8868 2 snd_intel8x0,snd_pcm

[end of output from lsmod | grep snd ]

sound info part from the output of lspci -vv:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
  Subsystem: IBM Device 1f00
  Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
  Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  Latency: 0
  Interrupt: pin B routed to IRQ 17
  Region 0: I/O ports at 6000 [size=256]
  Region 1: I/O ports at 6400 [size=64]
  Region 2: Memory at 80200000 (32-bit, non-prefetchable) [size=512]
  Region 3: Memory at 80200400 (32-bit, non-prefetchable) [size=256]
  Capabilities: <access denied>
  Kernel driver in use: Intel ICH

[end of output]

With the alsa packages in /usr/src/alsa, I ran these to install the 3 downloaded alsa packages:

bunzip2 alsa-driver-1.0.19.tar.bz2
tar -xf alsa-driver-1.0.19.tar
cd alsa-driver-1.0.19
./configure --with-cards=intel8x0 --with-sequencer=yes ; make ; make install

chmod a+rw /dev/dsp /dev/mixer /dev/sequencer

bunzip2 alsa-lib-1.0.19.tar.bz2
tar -xf alsa-lib-1.0.19.tar
cd alsa-lib-1.0.19
./configure ; make ; make install

bunzip2 alsa-utils-1.0.19.tar.bz2
tar -xf alsa-utils-1.0.19.tar
cd alsa-utils-1.0.19
./configure ; make ; make install

modprobe snd-intel8x0 ; modprobe snd-pcm-oss ; modprobe snd-mixer-oss ; modprobe snd-seq-oss

[End of what I ran.]

I don't know if other alsa packages (base, tools) hold the answer to this problem, and I don't know if something that recognizes hardware and what modules are installed is somehow screwed up now.




Without music life would be a mistake.  

 - Friedrich Wilhelm Nietzsche, philosopher (1844-1900)

Music is another planet.

 - Alphonse Daudet (1840-1897; French novelist)