you should find the alsa library in your /usr/lib directory
however, after building the alsa lib from hg repository head, i have the symbol defined:

$ objdump -T src/.libs/libasound.so.2.0.0 | grep snd_pcm_hw_params_set_rate_near
000496c0 g    DF .text  00000044 (ALSA_0.9)   snd_pcm_hw_params_set_rate_near
000449e0 g    DF .text  00000044  ALSA_0.9    __snd_pcm_hw_params_set_rate_near
000449e0 g    DF .text  00000044  ALSA_0.9.0rc4 snd_pcm_hw_params_set_rate_near

could you try on your library ?

-- Ben

Adam Bogacki wrote:
Merci Benoit !

 Hmm.. trying 'objdump -T [target]' gives me

Tux:/# objdump -T libasound libasound.so.2
objdump: 'libasound': No such file
objdump: 'libasound.so.2': No such file
Tux:/# objdump -T libasound.so.2

.. yet I can see that

Tux:~#  apt-cache showpkg libasound2
Package: libasound2
Versions:
1.0.11-5(/var/lib/apt/lists/ftp.nz.debian.org_debian_dists_unstable_main_binary-i386_Packages)(/var/lib/apt/lists/debian.paradise.net.nz_debian_dists_unstable_main_binary-i386_Packages)(/var/lib/apt/lists/ftp.debian.pacific.net.au_debian_dists_unstable_main_binary-i386_Packages)(/var/lib/dpkg/status)
1.0.11-4(/var/lib/apt/lists/debian.ihug.co.nz_debian_dists_unstable_main_binary-i386_Packages)

.. and

Dependencies:
1.0.11-5 - libc6 (2 2.3.6-6) libasound2-plugins (2 1.0.9)
libasound2-plugins (3 1.0.9)
1.0.11-4 - libc6 (2 2.3.6-6) libasound2-plugins (2 1.0.9)
libasound2-plugins (3 1.0.9)

.. and 

Tux:/# find -name libasound* -print
./home/doc/libasound1
./home/share/doc/libasound2
./home/share/doc/libasound1
./usr/share/doc/libasound2
./usr/share/doc/libasound2-dev
./usr/share/doc/libasound2-doc
./usr/share/doc/libasound2-plugins
.....<snip>....

Adam Bogacki,
afb@paradise.net.nz

On Mon, May 29, 2006 at 09:29:25AM +0200 or thereabouts, Benoit Fouet wrote:
  
what is the version of your libasound ?
alsa library uses a symbol versionning, try an objdump -T to see the
symbols version...

-- Ben

Adam Bogacki wrote:

    
Hi, following the last two apt-upgrades of libasound2, libasound2-dev,
& libasound2-plugins I have no sound with aplay, mplayer or ekiga, 
and keep getting the following ..

Tux:/home/cyberia/Music/Cuba2# aplay track-01.wav
Playing WAVE 'track-01.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
aplay: relocation error: aplay: symbol snd_pcm_hw_params_set_rate_near,
version ALSA_0.9.0rc4 not defined in file libasound.so.2 with link time
reference

mplayer gives me ..

AO: [esd] esd_open_sound failed: No such file or directory

and

Tux:~# /usr/bin/esd
/usr/bin/esd: relocation error: /usr/lib/libesd.so.0: symbol
snd_pcm_hw_params_s et_rate_near, version ALSA_0.9.0rc4 not defined in
file libasound.so.2 with link time reference

.. libasound2 seems to be missing something. When is the next upgrade ?

Adam Bogacki,
afb@paradise.net.nz
 

------------------------------------------------------------------------

_______________________________________________
Alsa-user mailing list
Alsa-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/alsa-user
 

      

_______________________________________________ Alsa-user mailing list Alsa-user@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/alsa-user