Thanks for the hint!

Your suggestion didn't work at first but as soon as I additionally changed the check inside the ./configure from 2.6 to 2.4 I was able to compile it...
I am working with a modified version of the alsa drivers from realtek and after some other teaks I managed to finally get sound working on my machine!

Thanks again,

On Fri, Feb 29, 2008 at 7:19 AM, Clemens Ladisch <> wrote:
David wrote:
> I am running on a Linux kernel 2.4 (CentOS 3) and I was just trying to
> compile the latest alsa drivers (1.0.16) for a Realtek ALC260 soundcard, but
> when running " ./configure --with-cards=hda-intel" I get the following
> error:
> checking for which soundcards to compile driver for... configure: error:
> Unsupported soundcard hda-intel
> By looking inside the ./configure script I can see that this driver is only
> compiled if the following test holds true:
> ( test "$kversion.$kpatchlevel" = "2.6" )
> Which is obviously false on my machine running a 2.4 kernel.
> Is there any workaround this issue? Is the support of the 2.4 kernel on this
> driver expected any time soon? Or should I simply give up having sound on
> this machine (I cannot move up to the 2.6 kernel due to other constraints)?

The snd-hda-intel driver does not compile on 2.2 kernels, so it has an
entry in the kconfig-vers file to disable it on those kernels.  However,
the kconfig-vers entry says "2.6" because the utils/mod-deps utility
that generates that part of the configure script does not support any
version checks with numbers less than 2.6.

If you don't want to fix mod-deps, just remove the entry from
kconfig-vers and run "./hgcompile --with-cards=hda-intel".