Hello everybody,

I am running on a Linux kernel 2.4 (CentOS 3) and I was just trying to compile the latest alsa drivers (1.0.16) for a Realtek ALC260 soundcard, but when running " ./configure --with-cards=hda-intel" I get the following error:

checking for which soundcards to compile driver for... configure: error: Unsupported soundcard hda-intel

By looking inside the ./configure script I can see that this driver is only compiled if the following test holds true:

( test "$kversion.$kpatchlevel" = "2.6" )

Which is obviously false on my machine running a 2.4 kernel.

Is there any workaround this issue? Is the support of the 2.4 kernel on this driver expected any time soon? Or should I simply give up having sound on this machine (I cannot move up to the 2.6 kernel due to other constraints)?