But I didn't find any asound.conf or .asoundrc file. So I created that. I installed the latest ALSA driver. And my application that is Real Player and Audio Player (XMMS) use ALSA plugin rather than OSS.
I also checked with the GnomeMeeting which uses ALSA plugin. But in vain.

On 6/30/05, Andrew Haninger <> wrote:
On 6/30/05, Ashutosh Sharma < > wrote:
>      But nothing happened. Instead when I tried to do the modprobe
> snd-intel8x0 then it gave me the error related to the No Symbol Found etc.
For what it's worth, I followed the instructions given in this thread
about adding that block of configuration code to the /etc/asound.conf
file and now, even on my old OPL3SA2 card, where it's not supported in
hardware, I'm able to play multiple things at once using mplayer. I
have mplayer compiled to use the ALSA API by default. I haven't tried
it with OSS, but I'm guessing it wouldn't work considering what was
said earlier in the thread.

It's probable/likely that playing audio from the applications you're
using, simultaneously, won't work due to the OSS API that they are
using. Perhaps newer versions use ALSA and those will work.