Hi,

I just bought a laptop and installed debian next to Windows on aT dual boot. The only way I can get sound to work is with an .asoundrc file through my USB headset. It works perfectly that way, but I need sound through the system speakers.

Here is some information about my system:

e$ cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 19
 1 [Headset        ]: USB-Audio - Logitech USB Headset
                      Logitech Logitech USB Headset at usb-0000:00:12.0-5, full speed
 2 [Generic_1      ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb40000 irq 16

$ cat /proc/asound/devices
  2:        : timer
  3:        : sequencer
  4: [ 1- 0]: digital audio playback
  5: [ 1- 0]: digital audio capture
  6: [ 1]   : control
  7: [ 0- 3]: digital audio playback
  8: [ 0- 0]: hardware dependent
  9: [ 0]   : control
 10: [ 2- 0]: digital audio playback
 11: [ 2- 0]: digital audio capture
 12: [ 2- 0]: hardware dependent
 13: [ 2]   : control

$ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_usb_audio
 2 snd_hda_intel

$ lspci | grep Audio
00:01.1 Audio device: ATI Technologies Inc Device 1714
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)

# this makes sound work with my headset. i've tried choosing different defaults without the headset, but nothing seems to work
$ cat .asoundrc
defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 0

When I run alsamixer, if I choose card 2, HD-Audio Generic (card 0 is also named HD-Audio Generic), I can see the usual 6-10 channels for the different devices and adjust them like usual, but if I choose the same card in gnome-volume-control, I can't see any channels at all, there is just a check in a box for IEC598. Gnome does not seem to recognize something I need it to recognize.

I know that the laptop tspeakers work, because they work in the Windows half of the dual boot. I can't use the FN button to adjust volume in Linux though, like I do in Windows. Pressing the FN + F8 key (volume up on my computer) in Linux brings up the little volume splash screen, but further presses do not adjust the volume in any way. I don't think this is the problem though. It seems that gnome doesn't recognize the sound card I want it to.

I have RTFM, at least a good part of it, but I'm a little confused as to how to proceed. A lot of things that have worked for other users I can't get to work for me. Any help you could offer would be much appreciated.

Bob