I have re-formatted my HD and re-installed Mandrake 8.2 with kernel 2.4.18 just to make sure I got rid of the older alsa drivers that I have tried earlier on. I have downloaded and extracted the latest development driver for alsa.
 
When I run './configure --with-cards=snd-emu1k01 --with-kernel=/usr/src/linux
 
I get the "syntax error"
             failed (probably missing /usr/src/linux/include/linux/version.h
 
The file is there, but all lines are commented out.
 
I have read the INSTALL HOWTO and somewhere there it mentioned that sources installed by distribution is incomplete. What should I do? Download the 2.4.18 tarball, extract and replace my source tree??
 
Thanks for your help.
 
Rick