Suse 9.0 hangs when loading atiixp

Help
bugfix
2004-06-13
2013-06-03
  • bugfix

    bugfix - 2004-06-13

    Hi all,

    I'm trying to get my soundcard working on an Compaq Pressario R3137EA.
    When I run LSPCI, I get the following output:
    0:14.5 Multimedia audio controller: ATI Technologies Inc: Unknown device 4341
    After some googling, I installed the latest version of ALSA. Alsaconfig recongnises the card, and wants to install the atiixp driver. Wich is good I presume.
    But when I restart the computer, or when I do a modprobe with the atiixp driver the notebook stops responding to everything. Only a hard reset helps.
    I am using Suse 9.0

    What am I doing wrong?

    Regards,

    Edwin.

     
    • Chromatic Distortion

      Nothing, as far as I can tell. BTW, what kernel are you running?
      You could try ->
      batch
      >modprobe --force snd-atiixp
      >dd if=/dev/urandom of=/dev/dsp
      Ctrl+D

      I've noticed that batching stuff at once will still get things completed, even if the machine stalls (at least on mine, anyway).

      Try a few different kernels, maybe an older driver?
      My ATI soundcard works perfectly with the snd-atiixp module in Suse 9.2

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks