snd-hda-intel problem

Help
Anonymous
2005-07-15
2013-06-03
  • Anonymous - 2005-07-15

    hello all!

    First, I couldn't make Audio work.

    I ran "lspci | grep -i audio" to find out which was my audio card 

    The output was:

    0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

    Reading every article I could have found on the net regarding this card, I discovered that i needed snd-azx (ALSA 1.0.8 ) or snd-hda-intel modules (ALSA 1.0.9rc* or later).

    I could make audio work but it was scratchy, noisy or disorted. Like when volumen is high; however, audio in XP is louder and sound 100% ok.

    Following the steps from here: http://www.ubuntulinux.org/wiki/HdaIntelSoundHowto

    I downloaded the lastest files from http://www.alsa-project.org to build and install ALSA 1.0.9 (1.0.9 release not the release candidates) and lately 1.0.9b.

    I've looked every on the net and found that I could use position_fix=1 or position_fix=2 to help me out but no good.

    I've tried in Ubuntu, Kubuntu, Debian and Fedora Core 4 (using the modules from the kernel) and it's the same problem in all of them.

    The card came with the mainboard Intel 915G (D915GEV or 915GEV)

    Thanks for the help,
    Santiago

     
    • ioGL-NX

      ioGL-NX - 2005-07-28

      Have the same problem here but I have a
      ASUS P4GPL-X and a Realtek ALC880.
      Never saw this have 5 Mobos from 915P - 955X never had this issue and there all works.

      lspci -vv gives me

      0000:00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 05)
              Subsystem: ASUSTeK Computer Inc.: Unknown device 8181
              Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
              Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
              Latency: 0, cache line size 04
              Interrupt: pin A routed to IRQ 10
              Region 0: Memory at d2df8000 (64-bit, non-prefetchable) [size=16K]
              Capabilities: [50] Power Management version 2
                      Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                      Status: D0 PME-Enable- DSel=0 DScale=0 PME-
              Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                      Address: 0000000000000000  Data: 0000
              Capabilities: [70] #10 [0091]

      This driver cause a crash and system hung.

      -> snip
      hda_codec: Unknown model for ALC880, trying auto-probe from BIOS...
      Unable to handle kernel NULL pointer dereference at virtual address 00000000
      printing eip:
      f88713f4
      *pde = 00000000
      Oops: 0002 [#1]
      PREEMPT
      last sysfs file:
      Modules linked in: snd_hda_intel snd_hda_codec nvidia
      CPU:    0
      EIP:    0060:[<f88713f4>]    Tainted: P      VLI
      EFLAGS: 00010293   (2.6.13-rc3-mm3pm)
      eax: fffffffe   ebx: f3b33548   ecx: 00000000   edx: 00000000
      esi: f3b33400   edi: 00000000   ebp: 00000006   esp: f0371ddc
      ds: 007b   es: 007b   ss: 0068
      Process modprobe (pid: 7398, threadinfo=f0370000 task=f4183560)
      Stack: 00000000 00000000 00000000 00000000 f3b33400 f3b33548 f0f1d000 f8871933
             f3b33400 f0f1d000 f8871bbd f8875478 f88748f6 00000001 f886d77e 00000f00
             00000005 00000000 f0f1d000 f54d04c0 00000000 f886d984 00000f00 00000002
      Call Trace:
      [<f8871933>]
      [<f8871bbd>]
      [<f886d77e>]
      [<f886d984>]
      [<f886d592>]
      [<c025b87e>]
      [<f8f5c871>]
      [<f8f5c100>]
      [<f8f5c220>]
      [<f8f5d533>]
      [<c026866a>]
      [<c02686be>]
      [<c02686f6>]
      [<c02bf763>]
      [<c02bf899>]
      [<c02bee1a>]
      [<c02bf8b6>]
      [<c02bf860>]
      [<c02bf30c>]
      [<c02bfc85>]
      [<c0268958>]
      [<c013b5c9>]
      [<c0102fcb>]
      Code: 31 c0 53 83 ec 10 89 d3 89 e7 f3 ab 8b 12 31 ff 83 fa 00 7e 45 89 f6 0f b7 44 7b 04 8d 48 ec 66 83 f9 03 77 13 8b 56 3c 83 e8 16 <66> 89 04 7a 8b 13 c7 04 8c 01 00 00 00 47 39 fa 7f da 31 ff 83
      -> snip

       

      Related

      Feature Requests: #1


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks