Module problems with SuSe Pro 9.3

Help
colpitts
2005-05-08
2013-06-03
  • colpitts

    colpitts - 2005-05-08

    Hi all,

    I've recently installed SuSe 9.3 Pro onto my Shuttle SN25P machine. The machine has an on-board sound chip from VIA/ICEnsemble.

    SuSe (or rather, the YaSt tool) detects that the chip is a 'VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller' but when trying to install the snd-ice1724 module by default it fails and gives the following message:

    'The kernel module snd-ice1724 for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.'

    I've tried other kernel modules with no success (as to be expected). I also tried using the OSS modules, which did give me the ability to change some of the module options. I've no idea how to alter this correctly though and all experimentation failed.

    I have got the sound chip working in Windows, as I was provided with a driver disc from Shuttle. Windows reports the installed driver as an 'Envy24 Family Audio Controller WDM for Shuttle Only'.

    It sounds like this might be a fairly specific piece of hardware, hence the problems. I did also try booting up Knoppix to see if that would help, but that also failed on the sound card detection.

    If anyone has any ideas on solving this I'd be grateful to hear from you.

    Many thanks.

     
    • Chromatic Distortion

      Did you try using modprobe with the -f switch?

      If it's invalid IRQ parameters, look up what YaST thinks the IRQ is, then go into your BIOS and change the settings of your soundcard. Might also check to see what Windows thinks your IRQ is.

      You also might want to look into the setserial command. This changes where the kernel thinks all the devices are. I don't know much about it, but if all else fails...

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks