Eoghan Doyle - 2010-05-04

Alsa Info

When recording I get intermittent overrun errors. See arecord output below.
I can hear what should be recorded clearly through the speakers.
The recording is OK except for the occasional hiccough.

## +                                               | 05%overrun!!! (at least -1351834332.006 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004251.292033000
  tstamp      : 1273004251.292325000
  delay       : 1365
  avail       : 0
  avail_max   : 35
##+                                                | 03%overrun!!! (at least -1351834332.010 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004407.404071000
  tstamp      : 1273004407.404331000
  delay       : 1365
  avail       : 0
  avail_max   : 0
## +                                               | 04%overrun!!! (at least -1351834332.013 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004608.844184000
  tstamp      : 1273004608.844409000
  delay       : 1365
  avail       : 0
  avail_max   : 0
##  +                                              | 07%overrun!!! (at least -1351834332.016 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004860.648457000
  tstamp      : 1273004860.648657000
  delay       : 1365
  avail       : 0
  avail_max   : 72
## +                                      ## +                                               | 05%overrun!!! (at least -1351834332.006 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004251.292033000
  tstamp      : 1273004251.292325000
  delay       : 1365
  avail       : 0
  avail_max   : 35
##+                                                | 03%overrun!!! (at least -1351834332.010 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004407.404071000
  tstamp      : 1273004407.404331000
  delay       : 1365
  avail       : 0
  avail_max   : 0
## +                                               | 04%overrun!!! (at least -1351834332.013 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004608.844184000
  tstamp      : 1273004608.844409000
  delay       : 1365
  avail       : 0
  avail_max   : 0
##  +                                              | 07%overrun!!! (at least -1351834332.016 ms long)
Status:
  state       : XRUN
  trigger_time: 1273004860.648457000
  tstamp      : 1273004860.648657000
  delay       : 1365
  avail       : 0
  avail_max   : 72
## +                                               | 04%^C
         | 04%^C

Note that the Delay is consistently 1365, this is very suspicous but I do not undestand its significance.

Any help would be apreciated, including pointers on how to debug.

Thanks,
Eoghan