#1 Help with ./configure.pl

open
nobody
None
5
2001-04-04
2001-04-04
Anonymous
No

i need help. I type in ./configure.pl and i get the
error message- Sitepm.Dir file not found - Program
HALTED please help!

Discussion

  • Cecilia Poittevin

    Logged In: YES
    user_id=189089

    I have the same problem. And the Sitepm.Dir doesn't exist.

     
  • Nobody/Anonymous

    Logged In: NO

    so you cant install it either

     
  • Nobody/Anonymous

    Logged In: NO

    You have to first edit your path.pm file (located in the
    conf folder) to reflect the correct paths. Then you have to
    run setpmdir.pl (default location is in the os_commerce
    folder). The script will automatically generate the
    Sitpm.Dir file. Then you can run ./configure.

     
  • Nobody/Anonymous

    Logged In: NO

    You have to first edit your path.pm file (located in the
    conf folder) to reflect the correct paths. Then you have to
    run setpmdir.pl (default location is in the os_commerce
    folder). The script will automatically generate the
    Sitpm.Dir file. Then you can run ./configure.

     
  • Nobody/Anonymous

    Logged In: NO

    i do not have a path.pm in my conf folder

     
  • Nobody/Anonymous

    Logged In: NO

    i uploaded a path.pm file to my conf folder with the
    following:

    sub setpaths {
    my $apath;
    $apath={};
    $apath = {
    acroot
    => '/usr/local/plesk/apache/vhosts/httpdocs/os_allco
    mmerce',
    bits =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/bits
    ',
    cgibin =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/cgi-
    bin',
    cgibin_om =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/cgi-
    bin/om',
    cgibin_om_admin =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/cgi-
    bin/om/admin',
    cgibin_ssl =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/cgi-
    bin/om/ssl',
    conf =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/conf
    ',
    crons =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/cron
    s',
    data =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/data
    ',
    html =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/html
    ',
    images =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/imag
    es',
    lib =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/lib'
    ,
    palm =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/palm
    ',
    ps
    =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/ps',
    tools =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/too'
    ,
    transit =>
    '/usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/tran
    sit',
    };
    return $apath;
    }
    1;

    This is my pat /usr/local/plesk/apache/vhosts/httpdocs/

    but when i run the ./setpmdir.pl command
    it comes back with:

    Setting drop files ...

    Checking directory: /home/httpd/os_allcommerce/cgi-bin/om
    Directory NOT found, skipping ..

    Checking directory: /home/httpd/os_allcommerce/cgi-
    bin/om/admin
    Directory NOT found, skipping ..

    Checking directory: /home/httpd/os_allcommerce/cgi-
    bin/om/ssl
    Directory NOT found, skipping ..

    Checking directory: /home/httpd/os_allcommerce/crons
    Directory NOT found, skipping ..

    Checking directory: /home/httpd/os_allcommerce/tools
    Directory NOT found, skipping ..

    Checking directory: /home/httpd/os_allcommerce
    Directory NOT found, skipping ..

    Error creating all Sitepm.Dir files. See setpmdir.log.

    Please help,
    Jalin

     
  • None OfYourbusiness

    Logged In: YES
    user_id=189121

    Did you tar zxvf os_allcommerce.1.2.3.tar.gz while you was
    in /usr/local/plesk/apache/vhosts/httpdocs/ ??
    If you did it, should of created
    /usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/ and
    a few sub directories under os_allcommerce. "conf" is one of
    them.

    You have to edit "path.pm" in your
    /usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/conf/
    and run "setpmdir.pl" in
    /usr/local/plesk/apache/vhosts/httpdocs/os_allcommerce/ .

    Don't forget that you have to be root when you do all this.
    If you need some more help email me at
    shannon@shannon.nyc.nu-net.com.

     
  • Nobody/Anonymous

    Logged In: NO

    I got everything to work but i cannot run the configure.pl
    because i do not have have root privilages
    Help

     
  • None OfYourbusiness

    Logged In: YES
    user_id=189121

    Sorry man. If you don't have root then you can't install
    allcommerce. Maybe you can ask your system administrator to
    install it for you?

     
  • Lee Herron

    Lee Herron - 2001-04-07

    Logged In: YES
    user_id=116321

    I have successfully installed AllCommerce without having
    root access -- I'm not sure why people feel you must have
    root access.

    There is a patch for that error that will be released next
    week -- in the mean time, find a copy of Sitepm.Dir in one
    of your other directories (cgi-bin perhaps) and place it in
    the directory from which it's missing. You do have to edit
    path.pm and run setpmdir.pl first.

     
  • Lee Herron

    Lee Herron - 2001-04-07

    Logged In: YES
    user_id=116321

    I have successfully installed AllCommerce without having
    root access -- I'm not sure why people feel you must have
    root access.

    There is a patch for that error that will be released next
    week -- in the mean time, find a copy of Sitepm.Dir in one
    of your other directories (cgi-bin perhaps) and place it in
    the directory from which it's missing. You do have to edit
    path.pm and run setpmdir.pl first.

     
  • Nobody/Anonymous

    Logged In: NO

    How did you do that without making the images on the login
    come from the root

     
  • None OfYourbusiness

    Logged In: YES
    user_id=189121

    Last time I checked, you have to be root to edit your
    http.conf and restart apache.

     
  • Techwiz

    Techwiz - 2001-04-10

    Logged In: YES
    user_id=192945

    Here's the simple fix. Go to the conf directory under the
    os_allcommerce installation,find path.pm and change the
    paths to whatever matches your install.. and you are smokin'

    Honestly, why do some people insist on making life harder
    than it already is?

     
  • Nobody/Anonymous

    Logged In: NO

    I have the same problem even as root and after editing the
    path.pm file myself

     
  • Andy Bolstridge

    Andy Bolstridge - 2003-08-11

    Logged In: YES
    user_id=646277

    I must say that the lastest version (1.2.3), you need root
    access to install - at least when I did this (after editing the
    path.pm file) I get a heap of error messages saying 'chown
    nobody:nobody : invalid user', followed by 'you are not root,
    try again with root provileges.'

    So, if you have a shared host, how do you install without
    root privileges, as you mention in an earlier comment?

    thanks.

     

Log in to post a comment.