archlinux quick-hack

Help!
2009-04-04
2013-04-15
  • Joerg Linsenmeier

    Hello all,

    as of now, archlinux is not supported by the install-script. But it isn't too difficult to get around the distro-test :) ...
    Archlinux uses bsd-style init, but - i didn't investigate a lot - seems to have it's own flavour. So edit the function GetRcdSlackware, remove the lines

    for i in ${startscripts} ; do
        if ! [ -x "${i}" ] ; then
          ISSLACK=0
        fi
      done

    after the ISSLACK=1
    and your done.
    install as usual, but libstdc++-libc6.2-2.so.3 isn't packaged in archlinux (at least not in an official repository), so you'll have to download it with the help of the wonderful install-script.

    Ullrich, thanks again for your long dedication to this project. If you care to add direct install-support for arch, i would be pleased to help with any information you would need. But i suspect i could well be the only arch+alc-user out there. Nonetheless, aside the rc.*-naming it seems quite like a slackware (init-wise) and the installation-process runs smoothly. The runlevels do lie in /etc/ and are named as follows:
    rc.local rc.local.shutdown rc.multi rc.shutdown rc.single
    Feel free to ask for more detailed information.

    Regards
    JoLi

     
    • Ullrich Sigwanz

      Ullrich Sigwanz - 2009-04-05

      Hi JoLi

      can you please send me the 5 files

      - rc.local
      - rc.local.shutdown
      - rc.multi
      - rc.shutdown
      - rc.single

      zipped in a tar.gz, so that I can analize them and do the intergration for Arch-Linux.
      Should be an easy fix.

      Can you please look, if there is a file like "rc.cups" or similar in the /etc directory

      > find /etc  -name  "rc.cups*"

      Thank you for reply
      Kind Regards

      Ullrich

       
    • Ullrich Sigwanz

      Ullrich Sigwanz - 2009-04-05

      Sorry - forgot my address ...

      usigwanz  _at_ sunrise _dot_ ch

      ;-)

       
    • Joerg Linsenmeier

      No problem - sent via personal mail...

       
    • Nobody/Anonymous

      hello joerg,

      i tried to do so to install the alc-900 driver on my arch linux system.
      it works, but when it comes to install the needed packages, the installer gives an error message and exits:
      "The execution of
        Rpm2Cpio /tmp/pipsplus-0.1b-1.i386.rpm
      failed!
      The installation will stop here!"

      /tmp/pipsplus-0.1b-1.i386.rpm does exist. "rpm2cpio" is a working alias for some application, yet when I type "Rpm2Cpio", the command is not found.

      I tried to look up the part of the script where the Rpm2Cpio command is issued, but "Rpm2Cpio" seems to not be metioned in install.sh (I searched case sensitive). "rpm2cpio" is mentioned about 5 times.

      do you have any idea whats wrong?

      I did try the howto for the alc900 driver given in the arch linux wiki, but it does not work on my computer (pipsplus doesnt start).
      I am using an up-to-date version of arch linux on x86_64.

      i dont know if you need the information, but the packages to be installed are:

      *** I would now install the needed packages by:
          rpm2cpio /tmp/pipsplus-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /tmp/pipsplus-epson-laser-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /tmp/pipsplus-epson-alc900-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /tmp/pipsplus-gtk-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          mkdir -p "/etc/pipsplus"
          chmod a+xr "/etc/pipsplus"
          mkdir -p "/etc/pipsplus/printers"
          chmod a+xr "/etc/pipsplus/printers"
          rm -f "/etc/pipsplus/printers/alc900.conf"
          if ! grep "^alc900" "/etc/pipsplus/modules.conf" >/dev/null 2>&1
          then
            echo "alc900 EPSON AL-C900 AL-C900" >> "/etc/pipsplus/modules.conf"
          fi
          chmod a+r -R "/etc/pipsplus"
          find /usr/lib/pipsplus   -noleaf -type d -exec chmod a+rx "{}" \;
          find /usr/share/pipsplus -noleaf -type d -exec chmod a+rx "{}" \;

      by the way, we could switch to german at any time.

      yours,
      david

       
      • Ullrich Sigwanz

        Ullrich Sigwanz - 2009-05-12

        Hi David,

        Rpm2Cpio is a function (subroutine) in the support-script alc900.pre!
        You can copy all 4 pipsplus-rpms into the directory where install.sh resides.
        This should work then ...

        If not, please keep me updated

        Greets
        Ullrich

         
    • Nobody/Anonymous

      Hello Ullrich,

      thanks for quick responding!

      Sadly, the Error stays similar:
      The Packages:
      * pipsplus
      * pipsplus-epson-laser
      * pipsplus-epson-alc900
      * pipsplus-gtk
      are not installed and need to be added to your installation.
      You will need the missing packages to utilize the features of the driver.

      *** I would now deinstall all files of the packages:
      * pipsplus
      * pipsplus-epson-laser
      * pipsplus-epson-alc900
      * pipsplus-gtk
      by just removing them via "rm -f", just to be sure
      that all older versioned files are removed from you system.

      Shall I do the proposed actions for you ?
      This time / Always / Never (t/a/n) [a] t
      Removing files ... done!
      0 files removed
      0 directories removed

      *** I would now install the needed packages by:
          rpm2cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-epson-laser-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-epson-alc900-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          rpm2cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-gtk-0.1b-1.i386.rpm | ( cd / && cpio -dium )
          mkdir -p "/etc/pipsplus"
          chmod a+xr "/etc/pipsplus"
          mkdir -p "/etc/pipsplus/printers"
          chmod a+xr "/etc/pipsplus/printers"
          rm -f "/etc/pipsplus/printers/alc900.conf"
          if ! grep "^alc900" "/etc/pipsplus/modules.conf" >/dev/null 2>&1
          then
            echo "alc900 EPSON AL-C900 AL-C900" >> "/etc/pipsplus/modules.conf"
          fi
          chmod a+r -R "/etc/pipsplus"
          find /usr/lib/pipsplus   -noleaf -type d -exec chmod a+rx "{}" \;
          find /usr/share/pipsplus -noleaf -type d -exec chmod a+rx "{}" \;

      Shall I do the proposed actions for you ?
      This time / Always / Never (t/a/n) [a] a
      ************************************************************************
      The execution of
        Rpm2Cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-0.1b-1.i386.rpm
      failed!
      The installation will stop here!

      -end-

      I had a look at alc900.pre . I'd love to help looking for the Problem, but I am not that much into writing scripts and don't really understand advanced ones like alc900.pre .

      I tried copy&pasting the command that the script said it will run before Rpm2Cpio failed, just to look what happens.

      # rpm2cpio /home/david/epson/alc900-cups-1.0.i386/pipsplus-0.1b-1.i386.rpm | ( cd / && cpio -dium )

      starts iterating the message "cpio: Malformed number " thousands of times in lightning speed.

      Yours,
      David

       
      • Ullrich Sigwanz

        Ullrich Sigwanz - 2009-05-12

        Hi David,

        I gues the error is in the rpm2cpio executable of the x64 sub system ...
        look in the install.sh directory
        there should be a script rpm2cpio and instead calling rpm2cpio (which is in /usr/bin) call

        ./rpm2cpio

        from whithin the install directory
        or to be sure

        /home/david/epson/alc900-cups-1.0.i386/rpm2cpio  blablabla

        Lot's of success
        Ullrich

         
    • Nobody/Anonymous

      update:
      I just found this on the debian bug report logs doing some search on the problem:

      "> cpio: Malformed number
      > cpio: Malformed number

      This happens because the devmajor and devminor fields in the
      tar header are both NULs, and cpio is trying to parse them as
      octal strings.

      Possibly this means it is assuming the wrong tar format."

      http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=425532

      greets,
      david

       
      • Joerg Linsenmeier

        hi david,

        can't help you much with rpm2cpio, as far as i remember i had no trouble with that. I can only guess ... i am still on 32bit, perhaps you do have some incompabilities with x86-64 (wrong rpm2cpio or something), or a broken download of the rpm?

        Funny thing is, i just checked and can't find any installed arch-package owning rpm2cpio, though i definitly have one in usr/bin (perhaps it was copied from the alc900-cvs???). The official package to get rpm2cpio seems to be "rpmextract".

        Mmh, as i said, i don't have a clue :)
        (But i did / do have some other struggles with arch & alc, main problem is to get arch playing along with the configuration-utilities (pipsplus-config)..., i'll tell more about these when i had a bit time to test it)

        Good luck,
        JoLin

         
    • Nobody/Anonymous

      hello,

      I tried to use the rpm2cpio-script downloaded along with alc900-cups. ./rpm2cpio pipsplus-0.1b... .rpm > package.cpio
      did work!
      so I tried to figure out how to change the alias of command line-rpm2cpio to the working script and did just uninstall the package "rpmextract", which does contain rpm2cpio. it worked then!

      thanks for helping!

      But I do have another problem:

      Starting AcuLaser C900 (alc900.daemon )
      nice: /usr/sbin/pipsplusd: Datei oder Verzeichnis nicht gefunden
      nice: /usr/sbin/pipsplusd: Datei oder Verzeichnis nicht gefunden
      Waiting for AcuLaser C900 daemon to come up .WARNING: *** no "alc900.daemon" is up!

      in fact there is a file /usr/sbin/pipsplusd , which can be chmod'ed, copied and symlinked to. But when I tried to execute it:

      bash-3.2# /usr/sbin/pipsplusd
      bash: /usr/sbin/pipsplusd: Datei oder Verzeichnis nicht gefunden

      there is another file in that directory, called pipsplusd.sh :

      bash-3.2# /usr/sbin/pipsplusd.sh
      /usr/sbin/pipsplusd.sh: line 30: /etc/rc.d/init.d/functions: Datei oder Verzeichnis nicht gefunden

      "Datei oder Verzeichnis nicht gefunden" means "File or Directory not found"

      Checking the Installation with install.sh turns out:

      Do you want me to (re-)check your installation now (y/n)? [y] y

      **********************************
      current driver version: 1.0
      **********************************
      /usr/share/alc900-cups/rc.alc900 ... Version:1.49 Date:2008/12/26
      /usr/bin/alc900.daemon ... Version:1.40 Date:2008/07/13
      /usr/bin/alc900.cups ... Version:1.40 Date:2008/11/02
      /usr/bin/alc900.connect ... Version:1.11 Date:2008/07/16
      /usr/bin/alc900.connect-gtk ... Version:1.6 Date:2008/06/15
      /usr/bin/alc900.post ... Version:1.36 Date:2008/12/31
      /usr/bin/alc900.update-uris ... Version:1.8 Date:2008/08/09
      /usr/bin/alc900.wakeup ... Version:1.9 Date:2007/12/19
      /usr/share/pipsplus/collate.sh ... Version:1.3 Date:2007/02/12
      ======== checking runlevels ========
      /etc/rc.d/rc.pipsplus ... Version:1.29 Date:2008/03/29
      ======== checking backends ========
      /usr/lib/cups/backend/alc900 ... Version:1.18 Date:2008/05/01
      ======== checking services ========
      CUPS daemon          -> pid(cupsd)         = 4837, OK!
      *** PIPS-PLUS daemon not needed to be up, OK!
      *** ACULASER C900 daemon is down, -> rcpipsplus restart
      ======== checking files and directories ========
      /usr/bin/alc900.cat ... Version:1.16
      /usr/bin/alc900.eoj ... Version:1.6
      /usr/bin/alc900.invoke-uri ... Version:1.2
      /usr/bin/alc900.listdevices ... Version:1.9
      /usr/bin/alc900.lockfile ... Version:1.6
      /usr/bin/alc900.monitor-temp ... Version:1.1
      /usr/bin/alc900.isblack ... Version:1.5
      /usr/bin/alc900.draft ... Version:1.6
      /usr/bin/alc900.probelp ... Version:1.3
      /usr/bin/alc900.size ... Version:1.4
      /usr/bin/alc900.sleep ... Version:1.6
      /usr/bin/alc900.filter ... OK!
      /usr/bin/usleep ... OK!
      *** no "Printcap"-Entry in "/etc/cups/cupsd.conf", (warning)
      /usr/share/cups/model/Epson/Epson-AcuLaser_C900-alc900.ppd ... OK!
      /var/log/alc900.log ... OK!
      /etc/pipsplus/modules.conf ... OK!
      /var/spool/lpd ... OK!
      /var/spool/lpd/alc900_4187_o4LcptUT ... OK!
      *** pipe /usr/var/lib/pipsplus/alc900_4187_o4LcptUT not needed, OK!
      /usr/bin/alc900.post: line 332: /etc/pipsplus/pipsplus.conf: Datei oder Verzeichnis nicht gefunden
      *** the daemon could not connect to any interface, (fatal)
      *** /etc/printcap ... does not contain proper info, FAILED!
      *** /etc/pipsplus/printers/alc900_4187_o4LcptUT.conf MISSING!
      ======== end of tests ========
      **************** CHECK THE OUTPUT FOR ERRORS ***********
      probably the first error is the reason of all the others

      Do you want me to check your printer queue URIs now (y/n)? [y]

      Do you have any idea what the reason for this could be?

      Thanks a million!
      Greets,
      David

       
      • Ullrich Sigwanz

        Ullrich Sigwanz - 2009-05-16

        Hi David,

        if this is the problem exchange the line

          nice -n ${nicelevel} "$@"

        in /usr/share/alc900-cups/rc.alc900

        by just

        "$@"

        Greets
        Ullrich

         
    • Nobody/Anonymous

      Hi Ullrich,

      Now, if I try to execute /etc/rc.d/rc.pipsplus:

      bash-3.2# /etc/rc.d/rc.pipsplus restart
      Stopping AcuLaser C900 ()
      Starting AcuLaser C900 (alc900.daemon )
      bash-3.2# /usr/share/alc900-cups/rc.alc900: line 145: /usr/sbin/pipsplusd: Datei oder Verzeichnis nicht gefunden
      /usr/share/alc900-cups/rc.alc900: line 145: /usr/sbin/pipsplusd: Datei oder Verzeichnis nicht gefunden

      (File or path not found)
      There is no process called alc900.daemon or pipsplusd running. Printing isn't working, too.

      bash-3.2# /etc/rc.d/rc.pipsplus status
      alc900.daemon dead but pid file exists
      bash-3.2#

      This weird file sbin/pipspluds still can't be run. I rpmextract'ed the installation files and tried to run pipsplusd then, but this isn't working, too.

      Do you have a clue?

      Greets,
      David

       
    • Nobody/Anonymous

      Hello,

      a friend just told me that this problem could be related to me using a 64-bit GNU/Linux.

      Greets,
      David

       
    • Joerg Linsenmeier

      Hi Ullrich,

      just for fun tried a new cvs checkout. To keep you informed - the install.sh now does work on archlinux! Yay!

      And now the remaining problems: :)
      It comes up with "I could not detect any correct startup script directory..."
      So i naturally had to restart cups by hand. ("/etc/rc.d/cups restart")
      But, as indicated above, it installs cleanly.

      Another thing, but quite probably specific for my setup: The esc/p-code-creation fails miserably. I think it did always since changing to archlinux. I assume that's why i can't prind postscript directly, always has to convert them to pdf. Now that's a bit annoying but with the cups-pdf-printer no problem, so i didn't investigated further. For the sake of completeness i add the output of alc900.post at the end.

      Greetings, Jörg

      **********************************
      current driver version: 1.1      
      **********************************
      /usr/share/alc900-cups/rc.alc900 ... Version:1.50 Date:2009/02/02
      /usr/bin/alc900.daemon ... Version:1.40 Date:2008/07/13          
      /usr/bin/alc900.cups ... Version:1.40 Date:2008/11/02            
      /usr/bin/alc900.connect ... Version:1.12 Date:2009/02/02         
      /usr/bin/alc900.connect-gtk ... Version:1.8 Date:2009/02/06      
      /usr/bin/alc900.post ... Version:1.37 Date:2009/03/01            
      /usr/bin/alc900.update-uris ... Version:1.9 Date:2009/02/02      
      /usr/bin/alc900.wakeup ... Version:1.9 Date:2007/12/19           
      /usr/share/pipsplus/collate.sh ... Version:1.3 Date:2007/02/12   
      ======== checking runlevels ========                             
      /etc/rc.d/rc.pipsplus ... Version:1.29 Date:2008/03/29           
      ======== checking backends ========                              
      /usr/lib/cups/backend/alc900 ... Version:1.18 Date:2008/05/01    
      ======== checking services ========                              
      CUPS daemon          -> pid(cupsd)         = 22727, OK!          
      *** PIPS-PLUS daemon not needed to be up, OK!                   
      ACULASER C900 daemon -> pid(alc900.daemon) = 22826, OK!          
      ======== checking files and directories ========                 
      /usr/bin/alc900.cat ... Version:1.16                             
      /usr/bin/alc900.eoj ... Version:1.6                              
      /usr/bin/alc900.invoke-uri ... Version:1.2                       
      /usr/bin/alc900.listdevices ... Version:1.9                      
      /usr/bin/alc900.lockfile ... Version:1.6                         
      /usr/bin/alc900.monitor-temp ... Version:1.1                     
      /usr/bin/alc900.isblack ... Version:1.5                          
      /usr/bin/alc900.draft ... Version:1.6                            
      /usr/bin/alc900.probelp ... Version:1.3                          
      /usr/bin/alc900.size ... Version:1.4                             
      /usr/bin/alc900.sleep ... Version:1.6                            
      /usr/bin/alc900.filter ... OK!                                   
      /usr/bin/usleep ... OK!                                          
      *** no "Printcap"-Entry in "/etc/cups/cupsd.conf", (warning)    
      /usr/share/cups/model/Epson/Epson-AcuLaser_C900-alc900.ppd ... OK!
      /var/log/alc900.log ... OK!                                      
      /etc/pipsplus/modules.conf ... OK!                               
      /var/spool/lpd ... OK!                                           
      /var/spool/lpd/alc900_22117_W3BIpTQ8 ... OK!                     
      *** pipe /usr/var/lib/pipsplus/alc900_22117_W3BIpTQ8 not needed, OK!
      the desired interface and the set one match, OK!                    
      /etc/printcap ... contains proper info OK!                          
      /etc/pipsplus/printers/alc900_22117_W3BIpTQ8.conf ... contains proper info OK!
      ======== cecking daemon control ========                                     
      getting wait-id of the idling DAEMON ... [25521]                             
      waking up the daemon ... [25923] is the new wait-id, OK!                     

      ======== testing ESC/P-Code - Generation ========
      *** glibc detected *** alc900.filter: double free or corruption (!prev): 0x09256008 ***
      ======= Backtrace: =========                                                          
      /lib/libc.so.6[0xb7ea69b1]                                                            
      /lib/libc.so.6[0xb7ea80b2]                                                            
      /lib/libc.so.6(cfree+0x6d)[0xb7eab17d]                                                
      alc900.filter[0x804a8e7]                                                              
      alc900.filter[0x804a465]                                                              
      /lib/libc.so.6(__libc_start_main+0xe6)[0xb7e51a36]                                    
      alc900.filter(geteuid+0x41)[0x8049881]                                                
      ======= Memory map: ========                                                          
      08048000-080bb000 r-xp 00000000 08:03 3446       /usr/bin/alc900.filter               
      080bb000-080bc000 rwxp 00073000 08:03 3446       /usr/bin/alc900.filter               
      09256000-092a2000 rwxp 00000000 00:00 0          [heap]                               
      b7b00000-b7b21000 rwxp 00000000 00:00 0                                               
      b7b21000-b7c00000 ---p 00000000 00:00 0                                               
      b7c1a000-b7c37000 r-xp 00000000 08:03 1174       /usr/lib/libgcc_s.so.1               
      b7c37000-b7c38000 rwxp 0001c000 08:03 1174       /usr/lib/libgcc_s.so.1               
      b7c69000-b7e2e000 rwxp 00000000 00:00 0                                               
      b7e2e000-b7e38000 r-xp 00000000 08:03 676        /lib/libnss_files-2.10.1.so          
      b7e38000-b7e39000 r-xp 00009000 08:03 676        /lib/libnss_files-2.10.1.so          
      b7e39000-b7e3a000 rwxp 0000a000 08:03 676        /lib/libnss_files-2.10.1.so          
      b7e3a000-b7e3b000 rwxp 00000000 00:00 0                                               
      b7e3b000-b7f7b000 r-xp 00000000 08:03 689        /lib/libc-2.10.1.so                  
      b7f7b000-b7f7d000 r-xp 00140000 08:03 689        /lib/libc-2.10.1.so                  
      b7f7d000-b7f7e000 rwxp 00142000 08:03 689        /lib/libc-2.10.1.so                  
      b7f7e000-b7f81000 rwxp 00000000 00:00 0                                               
      b7f81000-b7f95000 r-xp 00000000 08:03 672        /lib/libpthread-2.10.1.so            
      b7f95000-b7f96000 ---p 00014000 08:03 672        /lib/libpthread-2.10.1.so            
      b7f96000-b7f97000 r-xp 00014000 08:03 672        /lib/libpthread-2.10.1.so            
      b7f97000-b7f98000 rwxp 00015000 08:03 672        /lib/libpthread-2.10.1.so            
      b7f98000-b7f9b000 rwxp 00000000 00:00 0                                               
      b7fa4000-b7fcc000 rwxp 00000000 00:00 0                                               
      b7fcc000-b7fcd000 r-xp 00000000 00:00 0          [vdso]                               
      b7fcd000-b7fe9000 r-xp 00000000 08:03 688        /lib/ld-2.10.1.so                    
      b7fe9000-b7fea000 r-xp 0001b000 08:03 688        /lib/ld-2.10.1.so                    
      b7fea000-b7feb000 rwxp 0001c000 08:03 688        /lib/ld-2.10.1.so                    
      bfa26000-bfa3b000 rwxp 00000000 00:00 0          [stack]                              
      /usr/bin/alc900.post: Zeile 489: 25940 Abgebrochen             alc900.filter 2> /dev/null
      *** alc900.filter did not output any ESC/P-Code - FAILED!                              
      *** alc900.filter return-code: 134                                                     

      ======== end of tests ========

      **************** CHECK THE OUTPUT FOR ERRORS ***********
      probably the first error is the reason of all the others

      ===============================================================
      REPLAY OF THE alc900.post PROTOCOL                            
      ===============================================================

      **********************************
      current driver version: 1.1      
      **********************************
      /usr/share/alc900-cups/rc.alc900 ... Version:1.50 Date:2009/02/02
      /usr/bin/alc900.daemon ... Version:1.40 Date:2008/07/13          
      /usr/bin/alc900.cups ... Version:1.40 Date:2008/11/02            
      /usr/bin/alc900.connect ... Version:1.12 Date:2009/02/02         
      /usr/bin/alc900.connect-gtk ... Version:1.8 Date:2009/02/06      
      /usr/bin/alc900.post ... Version:1.37 Date:2009/03/01            
      /usr/bin/alc900.update-uris ... Version:1.9 Date:2009/02/02      
      /usr/bin/alc900.wakeup ... Version:1.9 Date:2007/12/19           
      /usr/share/pipsplus/collate.sh ... Version:1.3 Date:2007/02/12   
      ======== checking runlevels ========                             
      /etc/rc.d/rc.pipsplus ... Version:1.29 Date:2008/03/29           
      ======== checking backends ========                              
      /usr/lib/cups/backend/alc900 ... Version:1.18 Date:2008/05/01    
      ======== checking services ========                              
      CUPS daemon          -> pid(cupsd)         = 22727, OK!          
      *** PIPS-PLUS daemon not needed to be up, OK!                   
      ACULASER C900 daemon -> pid(alc900.daemon) = 22826, OK!          
      ======== checking files and directories ========                 
      /usr/bin/alc900.cat ... Version:1.16                             
      /usr/bin/alc900.eoj ... Version:1.6                              
      /usr/bin/alc900.invoke-uri ... Version:1.2                       
      /usr/bin/alc900.listdevices ... Version:1.9                      
      /usr/bin/alc900.lockfile ... Version:1.6                         
      /usr/bin/alc900.monitor-temp ... Version:1.1                     
      /usr/bin/alc900.isblack ... Version:1.5
      /usr/bin/alc900.draft ... Version:1.6
      /usr/bin/alc900.probelp ... Version:1.3
      /usr/bin/alc900.size ... Version:1.4
      /usr/bin/alc900.sleep ... Version:1.6
      /usr/bin/alc900.filter ... OK!
      /usr/bin/usleep ... OK!
      *** no "Printcap"-Entry in "/etc/cups/cupsd.conf", (warning)
      /usr/share/cups/model/Epson/Epson-AcuLaser_C900-alc900.ppd ... OK!
      /var/log/alc900.log ... OK!
      /etc/pipsplus/modules.conf ... OK!
      /var/spool/lpd ... OK!
      /var/spool/lpd/alc900_22117_W3BIpTQ8 ... OK!
      *** pipe /usr/var/lib/pipsplus/alc900_22117_W3BIpTQ8 not needed, OK!
      the desired interface and the set one match, OK!
      /etc/printcap ... contains proper info OK!
      /etc/pipsplus/printers/alc900_22117_W3BIpTQ8.conf ... contains proper info OK!
      ======== cecking daemon control ========
      getting wait-id of the idling DAEMON ... [25521]
      waking up the daemon ... [25923] is the new wait-id, OK!

      ======== testing ESC/P-Code - Generation ========

      *** alc900.filter did not output any ESC/P-Code - FAILED!
      *** alc900.filter return-code: 134

      ======== end of tests ========

       
    • Ullrich Sigwanz

      Ullrich Sigwanz - 2009-08-15

      Hi,

      I also updated the final check in the CVS,
      hope it works now

      Kind Regards
      Ullrich

       
  • Jan Van Moer

    Jan Van Moer - 2009-11-12

    CVS version didn't work for me:

    got this error when I run alc900.post:

    **********************************

    current driver version: 1.1

    **********************************

    /usr/share/alc900-cups/rc.alc900 … Version:1.50 Date:2009/02/02

    /usr/bin/alc900.daemon … Version:1.40 Date:2008/07/13

    /usr/bin/alc900.cups … Version:1.40 Date:2008/11/02

    /usr/bin/alc900.connect … Version:1.12 Date:2009/02/02

    /usr/bin/alc900.connect-gtk … Version:1.8 Date:2009/02/06

    /usr/bin/alc900.post … Version:1.38 Date:2009/08/10

    /usr/bin/alc900.update-uris … Version:1.9 Date:2009/02/02

    /usr/bin/alc900.wakeup … Version:1.9 Date:2007/12/19

    /usr/share/pipsplus/collate.sh … Version:1.3 Date:2007/02/12

    ======== checking runlevels ========

    /etc/rc.d/rc.pipsplus … Version:1.29 Date:2008/03/29

    ======== checking backends ========

    /usr/lib/cups/backend/alc900 … Version:1.18 Date:2008/05/01

    ======== checking services ========

    *** CUPS daemon is down, please restart the CUPS daemon!

    *** PIPS-PLUS daemon not needed to be up, OK!

    *** ACULASER C900 daemon is down, -> rcpipsplus restart

    ======== checking files and directories ========

    /usr/bin/alc900.cat … Version:1.16

    /usr/bin/alc900.eoj … Version:1.6

    /usr/bin/alc900.invoke-uri … Version:1.2

    /usr/bin/alc900.listdevices … Version:1.9

    /usr/bin/alc900.lockfile … Version:1.6

    /usr/bin/alc900.monitor-temp … Version:1.1

    /usr/bin/alc900.isblack … Version:1.5

    /usr/bin/alc900.draft … Version:1.6

    /usr/bin/alc900.probelp … Version:1.3

    /usr/bin/alc900.size … Version:1.4

    /usr/bin/alc900.sleep … Version:1.6

    which: no alc900.filter in (/bin:/usr/bin:/sbin:/usr/sbin:/opt/java/jre/bin:/opt/kde/bin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core:/opt/qt/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin)

    *** alc900.filter not installed, (fatal)

    /usr/bin/usleep … OK!

    *** no "Printcap"-Entry in "/etc/cups/cupsd.conf", (warning)

    /usr/share/cups/model/Epson/Epson-AcuLaser_C900-alc900.ppd … OK!

    /var/log/alc900.log … OK!

    /etc/pipsplus/modules.conf … OK!

    /var/spool/lpd … OK!

    /var/spool/lpd/alc900_10943_ZiAqp3Dr … OK!

    *** pipe /usr/var/lib/pipsplus/alc900_10943_ZiAqp3Dr not needed, OK!

    the desired interface and the set one match, OK!

    *** /etc/printcap … does not contain proper info, FAILED!

    *** /etc/pipsplus/printers/alc900_10943_ZiAqp3Dr.conf MISSING!

    ======== end of tests ========

    **************** CHECK THE OUTPUT FOR ERRORS ***********

    probably the first error is the reason of all the others

    ===============================================================

    REPLAY OF THE alc900.post PROTOCOL

    ===============================================================

    **********************************

    current driver version: 1.1

    **********************************

    /usr/share/alc900-cups/rc.alc900 … Version:1.50 Date:2009/02/02

    /usr/bin/alc900.daemon … Version:1.40 Date:2008/07/13

    /usr/bin/alc900.cups … Version:1.40 Date:2008/11/02

    /usr/bin/alc900.connect … Version:1.12 Date:2009/02/02

    /usr/bin/alc900.connect-gtk … Version:1.8 Date:2009/02/06

    /usr/bin/alc900.post … Version:1.38 Date:2009/08/10

    /usr/bin/alc900.update-uris … Version:1.9 Date:2009/02/02

    /usr/bin/alc900.wakeup … Version:1.9 Date:2007/12/19

    /usr/share/pipsplus/collate.sh … Version:1.3 Date:2007/02/12

    ======== checking runlevels ========

    /etc/rc.d/rc.pipsplus … Version:1.29 Date:2008/03/29

    ======== checking backends ========

    /usr/lib/cups/backend/alc900 … Version:1.18 Date:2008/05/01

    ======== checking services ========

    *** CUPS daemon is down, please restart the CUPS daemon!

    *** PIPS-PLUS daemon not needed to be up, OK!

    *** ACULASER C900 daemon is down, -> rcpipsplus restart

    ======== checking files and directories ========

    /usr/bin/alc900.cat … Version:1.16

    /usr/bin/alc900.eoj … Version:1.6

    /usr/bin/alc900.invoke-uri … Version:1.2

    /usr/bin/alc900.listdevices … Version:1.9

    /usr/bin/alc900.lockfile … Version:1.6

    /usr/bin/alc900.monitor-temp … Version:1.1

    /usr/bin/alc900.isblack … Version:1.5

    /usr/bin/alc900.draft … Version:1.6

    /usr/bin/alc900.probelp … Version:1.3

    /usr/bin/alc900.size … Version:1.4

    /usr/bin/alc900.sleep … Version:1.6

    *** alc900.filter not installed, (fatal)

    /usr/bin/usleep … OK!

    *** no "Printcap"-Entry in "/etc/cups/cupsd.conf", (warning)

    /usr/share/cups/model/Epson/Epson-AcuLaser_C900-alc900.ppd … OK!

    /var/log/alc900.log … OK!

    /etc/pipsplus/modules.conf … OK!

    /var/spool/lpd … OK!

    /var/spool/lpd/alc900_10943_ZiAqp3Dr … OK!

    *** pipe /usr/var/lib/pipsplus/alc900_10943_ZiAqp3Dr not needed, OK!

    the desired interface and the set one match, OK!

    *** /etc/printcap … does not contain proper info, FAILED!

    *** /etc/pipsplus/printers/alc900_10943_ZiAqp3Dr.conf MISSING!

    ======== end of tests ========

    **************** CHECK THE OUTPUT FOR ERRORS ***********

    probably the first error is the reason of all the others

     
  • Joerg Linsenmeier

    Strange that you don't have alc900.filter…
    Do you have the pipsplus-rpm? I think the install.sh downloads it for you, but that would perhaps be the first thing to check…

    Greetings, linse

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks