java.lang.NoSuchMethodError. join on weblogic

2010-08-17
2013-01-31
  • Ciju George

    Ciju George - 2010-08-17

    Hello everyone,

    I tried to deploy 'ajaxtags-demo-1.5.1.war' on weblogic 10.3 server i am getting a
    java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.join(Ljava/util/Collection;Ljava/lang/String;)Ljava/lang/String;

    the same is working good on tomcat server

    Here is the stack trace

    java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.join(Ljava/util/Collection;Ljava/lang/String;)Ljava/lang/String;
    at net.sourceforge.ajaxtags.tags.OptionsBuilder.toString(OptionsBuilder.java:179)
    at net.sourceforge.ajaxtags.tags.AjaxTabPageTag.toString(AjaxTabPageTag.java:59)
    at net.sourceforge.ajaxtags.tags.AjaxTabPanelTag.addPage(AjaxTabPanelTag.java:85)
    at net.sourceforge.ajaxtags.tags.AjaxTabPageTag.doEndTag(AjaxTabPageTag.java:66)
    at jsp_servlet.__index._jsp__tag1(__index.java:241)
    at jsp_servlet.__index._jsp__tag0(__index.java:148)
    at jsp_servlet.__index._jspService(__index.java:105)
    at weblogic.servlet.jsp.JspBase.service(JspBase.java:34)
    at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
    at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
    at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:300)
    at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:183)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.doIt(WebAppServletContext.java:3686)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3650)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
    at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2268)
    at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2174)
    at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1446)
    at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

    Please guide me at this situation

    Thanks in advance,
    Ciju George

     
  • Victor Homyakov

    Victor Homyakov - 2010-08-17

    1. Use search - here are already two topics about this.
    2. Check the version of apache library "commons-lang.jar" in classpath of your server - it should be 2.3 or above (because StringUtils.join was first implemented in commons-lang version 2.3).
    3. Try to replace found commons-lang*.jar with newer one.

     
  • Ciju George

    Ciju George - 2010-08-18

    Thank you for your response.
    i have seeen the topics but it didn't help me.
    i said i deployed 'ajaxtags-demo-1.5.1.war' downloaded from sourcefrge.net on to both tomcat and weblogic 10.3 servers.
    'ajaxtags-demo is wrking fine on tomcat server but on weblogic server its throwing the servlet exception

    java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.join(Ljava/util/Collection;Ljava/lang/String;)

    i searched the exploded directory and found commons-lang-2.3.jar in it. I tried including commons-lang-2.5.jar also but the same exception.

    Note:I deployed the war file downloaded form sourceforge.net directly on the servers without any modification. this war is packed with commons-lang-2.3.jar , working fine on tomcat server but not on weblogic. I checked the classpath whether more than 1 commons-lang included in the classpath but not.

    Please Help,
    Ciju George.

     
  • Ciju George

    Ciju George - 2010-08-18

    It worked,  Thousand Thanks Victor

    Ciju George

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks