SourceForge has been redesigned. Learn more.

Error during installating ajax chat

  • Frank Sam Hu

    Frank Sam Hu - 2012-10-13

    I have this error when I run install.php:
    Warning: require(/home/username/public_html/chat/../global.php) : failed to open stream: No such file or directory in /home/username/public_html/chat/lib/custom.php on line 16

    Fatal error: require() : Failed opening required '/home/username/public_html/chat/../global.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/username/public_html/chat/lib/custom.php on line 16

    I have tried this, and this and this without any good result…

    Additional info:
    My files are hosted in hostgator, the path is

  • Philip Nicolcev

    Philip Nicolcev - 2012-10-18

    I hate these file path issues. It seems to be the biggest cause of problems for people using shared hosts with weird setups or IIS.

    Your actual filepath to ajax chat is this: /home/username/public_html/chat/lib/custom.php
    Whatever integration version you're using is attempting to find your forum's global.php file in /home/username/public_html/chat/../global.php
    Which should actually look like

    First make sure you have global.php in your root directory. If you don't, you need to figure out where chat should be looking for global.php (it looks like you're using vBulletin integration so it would be in your vBulletin root folder).

    Then you need to change the line in custom.php that is searching for this file. So in lib/custom.php change
    To the actual proper path to your global.php file. Something like this

    Since I didn't make the vbulletin integration I'm not clear on why custom.php has a chdir before the require line. Hopefully that is not causing an issue.


Log in to post a comment.