My mistake.  The "compiling with linux 2.4" page under docs says to "apply the 2.4.3 patch (should work with most versions of 2.4)".  I took that too literally.

Perhaps I should be more specific about my situatoin.  I purchased DTN Speed Net's ( wireless internet access.  It's currently my only non-dialup option.  I have a Cisco 350 PCI card for a desktop, 50 ft. of RG8 coax cable, and a yagi style (spelling?) directional antenna.

    With a 2.4.17 kernel compile using the airo code that comes with it (1/01 timeframe I think), I've had the following problems:

- at best, throughput, signal strength, and signal quality are lower than with the same wireless hardware (different PC) on Windows XP.
- the throughput, strength and quality eventually degrades to loss of assoctiation with the access point all together (i.e. no connectivity).  This appears to only be rectified by taking the card out and re-seating it (perhaps powering system down for a few secons/minuts would suffice).

Next, I did as you suggested ... copied the airo source and heaers into the 2.4.17 source tree and recompiled.  This didn't appear to aleviate the above problems, and additionally introduced some kernal instability such as:

- hung once during boot up at time of airo card discovery
- no longer powers itself off at shutdown.  Instead makes loud beeping noices, and can only be stopped by disconecting the power at the wall.
- it's possible that it was the cause of a mysterious system reboot, but I can't confirm that it wasn't just a brief power outage or something instead.

In short, for this solutoin to meet all of my needs, I have to have an internet routable IP address on my Linux gateway (meaning the wireless card has to be in my linux box, or it has to be replaced with some kind of external access point).  I only have 2 more weeks, at most, left before my money back guarantee time of 30 days runs out.

    I'm looking for any and all suggestion/things to try to get this working stable.


Benjamin Reed wrote:
That patch was only for 2.4.3.  In later kernels you
just need to copy airo.c, airo.h, and airo_cs.c over
the existing files in the kernel sources.


--- Cory Steers <> wrote:
  I'm having some trouble compiling my kernel after
patching it with CVS
code. I've tried this with a 2.4.7 and 2.4.17
kernel. If my kernel
source is in /usr/src/linux and my CVS patches are
/usr/src/airo-linux, I cd to /usr/src/ and type
"patch -p0 < airo-linux/kernel/patches/2.4.3.patch"
and get the
following errors:

patching file linux/drivers/net/
Hunk #1 FAILED at 254.
1 out of 1 hunk FAILED -- saving rejects to file
patching file linux/drivers/net/Makefile
Hunk #1 succeeded at 94 (offset 5 lines).
patching file linux/drivers/net/pcmcia/
Hunk #1 succeeded at 31 (offset 1 line).
Hunk #2 FAILED at 40.
1 out of 2 hunks FAILED -- saving rejects to file
patching file linux/drivers/net/pcmcia/Makefile
patching file linux/Documentation/
Hunk #1 succeeded at 8650 with fuz z 1 (offset 1340

After looking at linux/drivers/net/ it
appears that ~ ling
290 something is where it wants to put the code. I
don't think it's
necessary anyway, because sources
drivers/net/wireless/ which has a spot for

I have no idea what
linux/drivers/net/pcmcia/ wants to do.
I can't match the rej stuff to anything in that
Config file. I decided
to not worry about it, because I'm not running on a
laptop, and
therefore not using pcmcia.

Next, I move linux/drivers/net/wireless/airo.c and
airo_cs.c to
airo-old.c and airo_cs-old.c respectively. I copy
airo-linux/kernel/airo.c airo.h and airo_cs.c to
linux/drivers/net/wireless. I run "make
menuconfig", configure the
kernel, and then successfully run "make dep". When
I run "make bzImage"
I get the following errors:

gcc -D__KERNEL__ -I/usr/src/linux/inclu de -Wall
-Wno-trigraphs -O2 -fomit-frame-pointer
-fno-strict-aliasing -fno-common
-pipe -mpreferred-stack-boundary=2 -march=i586
rm -f net.o
ld -m elf_i386 -r -o net.o tulip/tulip.o airo.o
Space.o setup.o
net_init.o loopback.o ppp_generic.o slhc.o
ppp_async.o ppp_synctty.o
ppp_deflate.o bsd_comp.o auto_irq.o
ld: cannot open airo.o: No such file or directory
make[3]: *** [net.o] Error 1
make[3]: Leaving directory
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory
make[1]: *** [_subdir_net] Error 2
make[1]: Leaving directory `/usr/src/linux/drivers'
make: *** [_dir_drivers] Error 2

Any help would be greatly appreciated.


Airo-linux-general mailing list

Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!