2.6er kernel and D-Link 610 ( 510 in US )

Numer0bis
2004-07-18
2004-07-19
  • Numer0bis

    Numer0bis - 2004-07-18

    Hi @ll

    I have a problem with setting up my wireless lan card. Everything worked fine. Wlan0 is showing, with iwconfig or ifconfig i can see the card, also the link led of the card is on, and the acitiviy led is blinking, but i can't ping anything. And the adress of ap is correct, when i type iwconfig i can see the mac adress of the ap and the sidd is also correct: i use default. I turned off the encryption because i think its easier for the first time to set it up. I seriously dont know why i cant ping anything. Does somebody know why?

    I am using Fedora core 2 with a patched 16k stack kernel from linuxant.com

    greetz Numer0bis

     
    • Numer0bis

      Numer0bis - 2004-07-19

      i now tried the card under winxp on the same machine, its working like charm. Even if i set it on dhcp, under linux with dhcp, he can't find the ap and the adress of the ap gets fautly : ff:ff:ff:ff:ff
      when i define the adress of my card and gateway and so on, he can find the ap, but no transmission is avaible

      here ifconfig and iwconfig, when i set my card manually: (not dhcp)

      [root@laptop ndiswrapper-0.8]# iwconfig
      lo        no wireless extensions.

      sit0      no wireless extensions.

      wlan0     IEEE 802.11b  ESSID:"yer-lan"  Nickname:"laptop.at.home"
                Mode:Ad-Hoc  Frequency:2.437GHz  Cell: 02:E0:89:A0:E4:3A
                Bit Rate=11Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
                RTS thr=2432 B   Fragment thr=2432 B
                Encryption key:off
                Power Management:off
                Link Quality:100/100  Signal level:-95 dBm  Noise level:-256 dBm
                Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
                Tx excessive retries:0  Invalid misc:0   Missed beacon:0

      [root@laptop ndiswrapper-0.8]# ifconfig
      lo        Protokoll:Lokale Schleife
                inet Adresse:127.0.0.1  Maske:255.0.0.0
                inet6 Adresse: ::1/128 Gltigkeitsbereich:Maschine
                UP LOOPBACK RUNNING  MTU:16436  Metric:1
                RX packets:1977 errors:0 dropped:0 overruns:0 frame:0
                TX packets:1977 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlnge:0
                RX bytes:3558866 (3.3 Mb)  TX bytes:3558866 (3.3 Mb)

      wlan0     Protokoll:Ethernet  Hardware Adresse 00:0D:88:64:CB:D1
                inet Adresse:192.168.1.25  Bcast:192.168.1.255  Maske:255.255.255.0
                inet6 Adresse: fe80::20d:88ff:fe64:cbd1/64 Gltigkeitsbereich:Verbindung
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlnge:1000
                RX bytes:0 (0.0 b)  TX bytes:19050 (18.6 Kb)
                Interrupt:10 Speicher:11000000-110000ff

      [root@laptop ndiswrapper-0.8]# ping 192.168.1.50
      PING 192.168.1.50 (192.168.1.50) 56(84) bytes of data.
      From 192.168.1.25 icmp_seq=0 Destination Host Unreachable
      From 192.168.1.25 icmp_seq=1 Destination Host Unreachable
      From 192.168.1.25 icmp_seq=2 Destination Host Unreachable

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks