How does one enable WEP mode using low level (eg /proc) writes to the aironet card after setting the WEP keys????

Here is some background material on our situation and what we have tried:

We have implemented a neighborhood wireless network using LRP firewalls which host cisco 340 ISA cards.  It works great thanks to the airo.o driver. 

Recently we have become a bit more concerned with security and would like to turn on WEP.

Everything we do with the 340 is via airo.o and writes to /proc/aironet/eth0/*

There seems to be no trouble setting the WEP keys using writes like:
echo 0 12:34:56:78:9A > /proc/aironet/eth0/WepKey

doing a cat on /proc../WepKey returns the correct status.

Once the WEP keys are set, we continue to communicate with the AP, but after arbitrary changes to the WepKey, communications continue, indicating that WEP encryption is not actually turned on.

Looking at the fancy windows and linux tools from cisco I can see that there is a separate place where one tells the card to *** enable WEP ***.   What is the equivalent in the world of lower level writes to the card?  We need to keep this very simple and rudimentary as the LRP firewalls are very minimal (and stable) systems.   We cannot bring up the fancy cisco tools on this minimal kernal.  Another echo to some /proc location is what we are looking for.

What has not worked:  changing "WEP: open" to "WEP: encrpyt" or "WEP: shared" in /proc/aironet/eth0/Config causes communications with the AP to be lost.  The AP is set for open and shared modes.  (It is a cisco 340 AP)

Many thanks,

Pete Dubler
pete@dublerfamily.com