MPI350 on IBM T30 with debian kernel 2.4.18

Anonymous
2002-08-21
2002-09-01
  • Anonymous - 2002-08-21

    I have an IBM T30 notebook with integrated wireless using the Cisco Mini-PCI 350 card (aka MPI350).

    As far as I can tell, the airo module which comes with debian's 2.4.18-686 kernel isn't aware of the MPI350 card.  No biggie, as I got the latest driver from Cisco (v2.0).  I did some fiddling, and finally got it talking to the company's wavelan infrastructure.

    Unfortunately, the module supplied by Cisco seems to have some issues, and I'm wondering if perhaps the CVS version of the airo module will help me resolve those issues.

    In particular, I'd like to be able to use the wireless-tools package.  I'm also having some issues with the network dying after a sleep and not coming back without a reboot.  I've tried down/up-ing the interface, but this rarely works.  I've tried taking the interface down, removing the module, reloading the module, and then re-running acu.  That sometimes works.  I'm having other issues, but this isn't a forum for the Cisco drivers, so I won't continue.

    So, to sum it all up:  Does anyone know if I should bother with the CVS version of the airo driver?  It seems to have been changed quite a bit from 0.1.

    (Sorry for the lack of coherency...  It's been a very long day.)

     
    • Anonymous - 2002-08-29

      Hmm.  That's what i get for posting when I'm tired.  I look dumb.

      Anyhow, I compiled the airo module from CVS, but got the same results (which is to say, nothing).  Didn't see the mini-pci card.

      On the other hand, I figured out that the cisco module starts with a default SSID of 'tsunami'.  I just added a script to /etc/network/if-pre-up.d which blanks out the SSID before trying to bring up the interface.  This causes it to scan for SSIDs.  Works well.

      Still can't use wireless-tools, so no fun wavelan-applet action.  Oh, well.

       
    • Chris Schuler

      Chris Schuler - 2002-09-01

      I finally got my MPI350 up and running (on a Dell 610 on Gentoo linux)  using the Cisco v2 drivers.  I had to run the kpciinstall and it compiled the mpi350.o module.  Once I set my WEP key, i was up and running on our network.

      Like you though (i think) iwconfig reports the device has no wireless extensions, and I have noclue how to put the device in rfmon since there is no /proc/driver/eth1/mpi350/config to set it in.

      I hope we can git airo-linux to support/work with this.  I am alos talking w/ MAX over at Wellenreiter inhopes of getting it to work w/ this card as well.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks