Kernel 2.4.23-pre8 and 350 firmware version

TC Wan
  • TC Wan

    TC Wan - 2003-10-27

    I've been trying to get the airo.c driver in 2.4.23-pre8 to work with my Aironet 350 PCMCIA card. Previous version of the airo.c driver (e.g., in 2.4.22-rc1) works fine with firmware 4.25.30. However, the new driver doesn't work with 4.25.30 or even with the newer 5.02.20 and 5.20.17 firmware. The airo.o module loads correctly, but would never detect or associate with any APs (AP MAC is always FF:FF:FF:FF:...)

    My currently workaround is to copy the airo.c from 2.4.22-rc1 to the 2.4.23-pre8 tree and recompile the airo.o module.

    Does anyone have any definite answer to what firmware version works with the 2.4.23-pre8 airo.c driver?

    • sldkjf

      sldkjf - 2003-10-29

      I am having the same problem (associating with an ap) as you describe, and I am using linux-2.6.0-test9.  (test 7 did this too)


    • TC Wan

      TC Wan - 2003-11-04

      The airo.c driver in 2.4.23-pre9 has been updated. This version seems to work with 4.25.30 and 5.20.17 as far as I can tell.

      However, running the CISCO provided acu utility will cause the
      card to disassociate and I need to 'cardctl eject' and 'cardctl insert' after quitting acu to reassociate to the AP (an old Cabletron AP)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks