Aironet 350 PCI Adapter w/ RedHat 7.1?

  • Anonymous - 2001-06-29

    Hi All:

    I recently purchased an Aironet 350 PCI card for a desktop machine running RedHat 7.1.

    I've tried building airo.o using the PCMCIA services with a 2.4.3 kernel as well as building the module using the standalone PCMCIA services with a 2.4.5 kernel.

    Either way, the result is pretty much the same.  I can "insmod airo.o" just fine and find the expected files in "/proc/driver/aironet/eth1".   However, the Config file shows a value of "Error" for "Mode", "PowerMode", and "Modulation"; and the adapter is unresponsive.

    I've tried the adapter in a Windoze 2K desktop system to confirm that the card does, in fact, work.

    I would certainly welcome any advice.


    • Anonymous - 2001-07-02

      Cisco now has drivers for the 340/350 wireless adapters on their website.  Seem to work OK. 
      Even has ACU to setup the cards...

    • Anonymous - 2001-07-02

      Thanks much for the tip.  I had previously tried (among other things) the AitoLinuxV10002 software from the CD that came with the adapter.

      I just now installed the pre-compiled modules from the AIROLINUXv15000 downloaded from cisco's WWW site.  Unfortunately, I get the same result ("Error" value for "Mode", "PowerMode", and "Modulation" in the Config file).

      Could it be an issue with the PCI adapter as opposed to a PCMCIA card?

      Has anyone else had success using a PCI adapter?


    • Anonymous - 2001-07-05

      I've found that I have no problem getting the PCI adapter working with RedHat 7.1 in an old Compaq desktop machine.  The other two RedHat 7.1 systems that I had tried previously are both HP Pavillion 8000 series (although they are slightly different models).

      There appears to be some sort of conflict/incompatability between the Aironet adapter and the PCI bus of these HP systems.  I'm not sure whether the issue is OS-dependent (i.e., I haven't tried to use the adapter in either of these two machines with an OS other than RedHat 7.1).

      I would like to use the Aironet card in the HP system which is my server/router, but I guess that issue is for a different forum.


    • Ken

      Ken - 2001-07-18

      I had trouble getting my RedHat kernel source to work when trying to compile the aironet driver. I needed a pci version for an LRP box running a 2.2.16 kernel (a homemade workgroup bridge - cisco want's $500 for one that supports 8 ips!). I wasn't worried about pcmcia card support.

      To get a pci card driver for aironet 350 cards that I could use with LRP, here's what I did:

      clean, full install slackware 7 (2.2.16 kernel) on an old pc.

      download, untar to /usr/src, and make config, make all, make install the pcmcia-cs-3.1.27 package from

      download and install the AIROLINUXv15000.tar.gz from cisco's site
      untar and run the cwinstall script, giving it the location of the pcmcia package.
      follow the instructions to recompile the pcmcia package again...

      This gives you a good airo.o in /lib/modules/2.2.16/pcmcia for 2.2.16 kernels that supports the cisco utilities and the 350 series pci cards.

      copy this file to an msdos floppy, boot lrp, mount the floppy (mount -t /dev/fd0 /mnt) and copy the airo.o file to /lib/modules. backup your lrp disk and reboot!

      This should work for pcmcia card support too, since I didn't see any errors when compiling, but I didn't try it.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks