Help save net neutrality! Learn more.
Close

Verify fails w/ dcfldd with USB to IDE cable

2007-11-13
2013-04-26
  • Nobody/Anonymous

    Since I ran into an image verify problem, I specifically setup a clean drive with 2 tiny partitions, simply for speed purposes.

    Scenario:

    Using latest version of Helix
    250GB WD IDE Hard Drive connected to a USB to IDE Cable
    I'm imaging /dev/sda1 which is a 1GB NTFS partition
    I'm writing it to a file on /dev/sda2 which is a 10GB ext3 partition
    I'm also choosing dcfldd, only because it's somewhat faster...
    No compression or other options chosen
    On the output I chose the 128k block-size, but for later trials, I used the 8k with the same failure.
    --------------------------------------------------------------------
    Here's the output:

    Start DCFLDD (md5): Tue Nov 13 00:01:46 MST 2007

    Hash will be calculated on /dev/sda1.

    Command-line:
    dcfldd hash=md5 hashwindow=0 hashlog=/tmp/hash.log status=off if=/dev/sda1 skip=0 conv=noerror ibs=131072 2>> /usr/local/share/air/logs/air.image.log | air-counter 2>> /usr/local/share/air/logs/air.buffer.data | dcfldd status=off of=/media/sda2/1g-test.dd seek=0 obs=131072 >> /usr/local/share/air/logs/air.image.log 2>&1
    8220+1 records in
    32882+1 records out
    32837+91 records in
    8220+1 records out
    Command completed: Tue Nov 13 00:03:12 MST 2007

    Start VERIFY: Tue Nov 13 00:03:12 MST 2007

    Verifying...

    Command-line: dcfldd if=/media/sda2/1g-test.dd hash=md5 hashlog=/tmp/verify_hash.log hashwindow=0 status=off | air-counter 2>> /usr/local/share/air/logs/air.buffer.data > /dev/null

    VERIFY FAILED: Hashes don't match
    Orig = Total (md5): 399afd76fa8516c7ba900d49634c75f7
    Copy = Total (md5): 60c5f7d033110fa81aea0d916f9e5828

    Command completed: Tue Nov 13 00:03:49 MST 2007
    --------------------------------------------------------------------

    Now, AIR with dd works like a champ, it only happens when I use dcfldd. 

    I decided to run a test. 
    I ran dcfldd from the command line with no extra commands/switches.
    I then ran the md5sum program to hash the original and the output file.
    I got a match running dcfldd MANUALLY.

    I would like to suggest that there may be a problem with the command that's getting output by AIR to dcfldd.

    The one thing that got me from that log file was this:
    -------------------
    8220+1 records in
    32882+1 records out  <---- +1?
    32837+91 records in  <---- +91?
    8220+1 records out
    -------------------

    Two more things:
    1. The USB to IDE cable DOES VERIFY fine when using dd, so i'm not prepared to start blaming the cable just yet.

    2. This same drive DOES VERIFY using dcfldd with the drive connected directly to the IDE bus.

    In conclusion, Steve, I really like AIR and prefer to use it for the same reason you do, it's faster than typing!  I like it for more reasons than that, but this is something I felt you needed to be aware of.  If you'd like to reach me, I can be found at keith#at#network#swat#team.com.  Thanks!

     
    • Steve Gibson

      Steve Gibson - 2007-11-23

      Keith, many thanks for the detailed report.  I'll definitely look into this and report back any findings or a resolution.

      -Steve

       

Log in to post a comment.