gaim/IRIX (and other Non-XFree86) HOWTO

2002-08-31
2013-01-14
  • Matt Williams

    Matt Williams - 2002-08-31

    I looked on here a while back and didn't find a solution for this, but on non-XFree servers you get stuff like:
    Gdk-ERROR **: BadMatch (invalid parameter attributes)
      serial 73644 error_code 8 request_code 62 minor_code 0
    Gdk-ERROR **: BadMatch (invalid parameter attributes)
      serial 73707 error_code 8 request_code 62 minor_code 0
    ... and gaim dies.  I think it's a Gtk+ issue, but since people probably people come here looking for a fix, I'm posting it here.  Maybe ./configure could disable these by default on an IRIX box?
    Workaround:
    [1] Hide buddy icons
    [2] Ignore font faces
    I'm not sure which of those two is the cause, but I have had troubles with both and my gaim has been trouble-free since I disabled both.
    PS Kudos to the gaim crew for such a kickass program :)

     
    • Luke Schierer

      Luke Schierer - 2002-08-31

      you actually managed to get gaim to run on irix?!?  wow. this is useful information. thanks for the report.

       
    • Caleb Shay

      Caleb Shay - 2002-09-05

      I've run into this problem with a lot of GTK+ apps on IRIX.  It seems to be a Visual problem.  IRIX, by default, uses a PseudoColor visual.  If your hardware supports 24 bit color (most do), you can fix this by editing /var/X11/xdm/Xservers and adding "-depth 24 -class TrueColor" to the end of the line in it.  This seems to have fixed all my problems with GTK+ programs crashing.

      Now if somebody could just tell me why I can't compile gaim-0.59.1:

      core.c: In function `UI_build':
      core.c:62: parse error before "int"

      and

      dialogs.c: In function `g_show_info_text':
      dialogs.c:1979: parse error before "char"

       
    • Eric Windisch

      Eric Windisch - 2002-11-16

      GAIM works great for me on Irix.. I built it around febuary/march 2002. I had to remove a line from the TOC file-sending code due to a problem with my machine's libiconv; otherwise, it works great.

       
    • Greg Bolcer

      Greg Bolcer - 2003-10-22

      0.64 binaries are available off of the SGI freeware site.  When you install, make sure you include the src.  Typically it puts it in /usr/freeware/src/gaim/ and there's a file patches that can be applied (for 0.64 only).  

      http://freeware.sgi.com/Dist/fw_gaim-0.64.tardist

      Irix 6.5, Gcc 3.3 binary also loaded from freeware will configure and compile 0.71.  I'm still struggling trying to get it to recognize any ssl libraries that I have installed.  The last compile worked using the below configure, the msn protocol linked statically, but then seems to encounter the dreaded IM Halloween problem (aka Oct 15).  The main GAIM page says non-Irix platforms will work post Oct 15 with correctly configured SSL libs.  Perl is disabled due to some gmake flag error which complains about compile and link flags conflicting that I didn't bother to figure out.

      ./configure --prefix=/usr/freeware --with-nspr-includes=/usr/freeware/mozilla --with-nspr-libs=/usr/freeware/mozilla --disable-perl --with-static-prpls=msn --enable-nss=static --with-nss-includes=/usr/freeware --with-nss-libs=/usr/freeware/mozilla/libnss3.so

       
    • Aaron

      Aaron - 2005-06-03

      I just got gaim 1.3.0 to compile on IRIX with mipspro compiler an SGI's Xserver.  It launches and logs in and gets my buddy list, and generally seems to work, but when I try to send a message (AIM) it says "Unable to send message" in the conversation text area of the window.
      I ran it in debug mode and it reported trying to send a message but all of the reported fields were 0.  Anyone know anything about this?
      *note to get gaim to compile I had to modify the file src/gtkft.c around line 550 there is an array of structs called labels[] initialized as it is declared (curly brace style) and mipspro disapproved of initializers with nonconstant elements so I unwrapped the initialization into a separate assignment statements and then it was ok.

      Thoughts?

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks