failed to open /dev/fuse: Permission denied

  • Thomas Goldschmidt


    I have some troubles mounting my Airport Extreme Disk via afp_mount.

    My machine runs a Debian Etch with afps-ng 0.8.1.

    When I run:
    afp_client mount -u <username> -p <mypw> avatarap:DATA /mnt/avatarap/

    I always get the following error:

    Mounting avatarap from DATA on /mnt/home/
    FUSE reported the following error:
    fusermount: failed to open /dev/fuse: Permission denied
    Unknown error 1, 2.

    I checked the permissions of /dev/fuse they seem to be ok. The problem perists even if I run the mount command as root.

    Any Idea?

    Tanks a lot!

  • Alex deVries

    Alex deVries - 2009-12-17

    What's the output of the following commands:
    ls -l /dev/fuse


    It looks like a fuse permission problem.  Also, afpfs-ng will not work as root (but it sure would be nice if it told you that).

    - A

  • Thomas Goldschmidt

    Here is the output:

        thomas fuse

        uid=1000(thomas) gid=1000(thomas) groups=113(fuse),1000(thomas)

        ls -l /dev/fuse:
        crw-rw--- 1 root fuse 10, 229 Dec 17 11:58 /dev/fuse

    Thanks for the fast response.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks