Advmenu 2.6.0 hang on exit

  • Michael.S.G.

    Michael.S.G. - 2013-02-05

    This also happens with Advmenu 2.5.0 (Not sure about previous versions).

    This is an odd problem, I have a workaround - But I'd rather not have to use it.
    I run Advmenu from Archlinux, It is run from .xinitrc when the user autologs in.
    (It can also be started via startx command - which loads .xinitrc)

    When I execute Advmenu directly from the .xinitrc it will hang on exit.
    (I am unable to kill it completly either - The process becomes "Defunt" - But stays listed!)

    The only way I can exit Advmenu is if I run it via workarounds, where it exit's ok.
    ie. (Currently 3 workarounds)

    exec xterm -bg black -geometry 0x0+0+0 -e advmenu
    screen advmenu
    nohup advmenu

    * I currently use this workaround.

    And thanks for the update (2.6.0), Advmenu is great!

  • Michael.S.G.

    Michael.S.G. - 2013-06-16

    Fantastic! I wish I had seen your reply earlier.

    I'll Let you know how the beta goes in the next few days.

    Last edit: Michael.S.G. 2013-06-16
    • Michael.S.G.

      Michael.S.G. - 2013-06-17

      Exiting from AdvMenu/xinit now works as expected.
      & Everything looks good as a Drop in replacement to 2.6.

      Thanks for the update.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks