SourceForge has been redesigned. Learn more.

Installation of Adminer failed

  • Harald

    Harald - 2014-05-12


    I tried to install Adminer on my Ubuntu 14.04 server in this way:
    sudo apt-get install adminer

    After the installation I made a restart:
    sudo service apache2 restart

    Then I tried to access adminer using http://123.456.789.0/adminer but I got a 404 Not Found page.
    BTW http://123.456.789.0/ works and I get the Apache2 Ubuntu Default Page.

    So I searched in the Adminer forum for installation hints and I found this: "simply put it on your web server with a .php extension and then go to your browser and put that in the address." What do you mean with " put it on your web server". I tried to put the adminer.php into my etc/apache2 folder, but this didn't work either. Isn't there an installation manual which explains everything for dummies?

    Thank you

    • lifeboy

      lifeboy - 2015-05-06

      The installation you described creates a file /etc/adminer.conf which you have to copy to /etc/apache2/sites-available/adminer.conf.

      Once you've done that (you need to be root or use sudo), use the "a2ensite adminer.conf" command to enable the site. All this does is create a symlink in /etc/apache2/sites-enabled/adminer.conf to point to /etc/apache2/sites-available/adminder.conf, as is the standard way with Apache2 under Ubuntu.

  • Paul

    Paul - 2014-05-13

    Is there a htdocs sub-folder in the etc/apache2 folder?

    If so, try placing it there. [that's where web apps go for my Apache installation]

    If not, then check the Apache httpd.conf file to see where the 'DocumentRoot' location is specified.

    Last edit: Paul 2014-05-13
  • Harald

    Harald - 2014-05-13

    Hi Paul,

    Thank you for your help. Under Ubuntu there is no httpd.conf file. But with your information I realized that the DocumentRoot under Ubuntu is /var/www/html. So I moved the adminer-4.1.0.php file into /var/www/html and started the browser (after a "sudo service apache2 restart") with http://123.456.789.0/adminer-4.1.0.php and ... here we are, it works!

  • Paul

    Paul - 2014-05-14

    Great!, good to know. [NOT an adminer issue; server config matter]

    Based on a quick google search, it appears that the 'DocumentRoot' location has changed with your Ubuntu version:

    The apache2 version that was published when the Ubuntu 14.04 release was made is 2.4.7 and starting with this version it seems that, for security reasons, the new root directory for the server is:


    So, from now, here you must to place the files for your (local) website. And like this you should not have this problem again with the future updates.

    Oh, and from the same information, there IS a config file down in the /etc/apache2 area, it may be called: /etc/apache2/apache2.conf, or possibly: /etc/apache2/sites-available/000-default.conf


    Last edit: Paul 2014-05-14

Log in to post a comment.