After login select database page is blank

  • John Edgley

    John Edgley - 2011-04-05

    Hi, I recently started using Adminer 3.2 with MySQL 5.1, and was delighted with it.

    I then upgraded PHP to 5.3.6 (from 5.2.8 I think) and now after login Adminer goes to a blank page (should be database select page). Versions 1 and 2 of Adminer all work correctly.

    I am on XPPro SP3, and although I can manage with Adminer 2.3 I'd prefer to be able to use the latest so any help would be greatly appreciated.

    Thanks in advance,


  • John Edgley

    John Edgley - 2011-04-05

    Sorry - should have made it clear this is on my development machine, localhost, IIS 5.1, and occurred with ISAPI on PHP 5.2, and also FastCGi on ISAPI in 5.3.6


  • John Edgley

    John Edgley - 2011-04-05

    Lol - too many hours at this - the previous comment is incomplete. What I meant to say is that I realised after the initial post that I actually think Adminer stopped working when I upgraded it from 3.2.0 to 3.2.2 but I performed the PHP upgrade shortly after and initially blamed that. Truth is I don't know whether it was the PHP upgrade or the Adminer upgrade that initially broke, however the rest is true - Ver 1 and 2 work with 5.3.6 and ver 3 doesn't!

    Sincere apologies for confusing the issue!


  • John Edgley

    John Edgley - 2011-04-21

    Hi, taking the liberty of bumping this - I am still using 2.3.2 because 3.x.x shows blank page after login. Sometimes I have to log in to 2.3.2 with localhost: (ie with the colon) as that sometimes also shows blank with just localhost.

  • Jakub Vrána

    Jakub Vrána - 2011-05-04

    Can you please try to input to the server field instead of localhost?

  • John Edgley

    John Edgley - 2011-05-06

    Hi jakub, I tried that and it made no difference - whatever I do with 3.x.x the page after login is blank. One thing I have found is that on hitting "login" the Visual Studio Debugger comes up (every time it seems) and says "An unhandled win32 exception occurred in inetinfo.exe".

    Strangely this also comes up quite often with 2.3.2, but doesn't seem to prevent Adminer from running, although usually the login doesn't work with "localhost" and I have to use "localhost:" (with the colon), and then if it doesn't work with the colon I have to try again without the colon, which never works, and then again with the colon, which always does!

    I don't think there's anything wrong with my setup, all Microsoft updates are in place and everything else works perfectly.

    Thanks in advance for any help you can offer.

  • Jakub Vrána

    Jakub Vrána - 2011-05-06

    I can't reproduce the problem and your description is confusing. Please find a combination under which Adminer 3.2.2 works then change one thing after which Adminer 3.2.2 will stop working.

  • John Edgley

    John Edgley - 2011-05-06

    I'm sorry, I thought I'd clarified the confusion caused by my earlier post, which in any event only related to why ver. 3..x..x stopped working.

    So, the situation is this;

    Whatever I use to login I have never had any version of 3.x working since I upgraded PHP to 5.3.6 and enabled FastCGI (full setup described above). As soon as I click on "login" I am presented with a completely blank page. I do get a Visual Studio Debugger window opening, with the error described above.

    I have gone back to ver. 2.3.2, which sometimes gives a blank page too, though I can always manage to use it using the "localhost:" login described above.

    I imagine the only combination which might make 3.2.2 work would be to go back to an earlier PHP without FastCGI enabled, which obviously I will not be doing, so I am unable to test.

  • Nobody/Anonymous

    Hi, I'm having some problems with adminer 3.2.2 and IIS.
    This is what i get after pressing login button:

    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    Those are the specs for my server:
    Host Database: localhost (
    OS Server: Windows NT 5.2 build 3790
    Database: MySQL 5.0.33
    PHP Version: 5.2.5 (Zend: 2.2.0)
    HTTP Server: Microsoft-IIS/6.0
    Server API: CGI/FastCGI

    Have to add that with Adminer 2.3.2 I have no problems.



  • Jakub Vrána

    Jakub Vrána - 2011-06-15

    Can you please create this file and run it instead of Adminer?

    function adminer_object() {
        class AdminerContentType extends Adminer {
            function headers() {
                header("Content-Type: text/html; charset=utf-8");
        return new AdminerContentType;
    include "./adminer.php"; // filename of your original Adminer
  • John Edgley

    John Edgley - 2011-06-16

    Hi Jakub, that made no difference for me… still blank after hitting "login".

  • Nobody/Anonymous

    Same situation here.  IIS 6 PHP 5.3.6 with MySQL and SQL Server 2005.  2.3.2 adminer works fine and can administer MySQL but any 3.x version gives a blank page after a 20-30 second timeout after clicking the login button.  Nothing in the php or iis logs and e_all is turned on.

  • Carsten Wiedmann

    Has anyone solved this problem?

    I'm trying to use adminer-4.0.2 on IIS 7.5 with PHP 5.5.7.

    If I try to login to a MySQL database, I always see the login form again after click on the login button.

    If I try to login to a SQLite3 database, I get a 404 error page from IIS.

    Both times the URI is always "http://example/adminer/"

    BTW: phpmyadmin (mysql) or phpliteadmin (sqlite) are working correctly...

  • Jakub Vrána

    Jakub Vrána - 2014-01-25

    After successful login, Adminer should redirect to adminer/?username=...
    Adminer needs REQUEST_URI or (ORIG_PATH_INFO and QUERY_STRING) variables to be set. Please verify your phpinfo() if they are there.


Log in to post a comment.