Access denied for user 'root'@'host'

  • nomadicME

    nomadicME - 2012-06-29

    The full error reported on login page of adminer (v3.3.4) is: Access denied for user 'root'@'host' (using password: YES)

    I can log in as root in phpmyadmin and from the command line using: mysql -uroot -p

    I can also log in as a normal user on this same host, but one of the main reasons I'm looking to get away from phpmyadmin is for tasks that require admin perms.

    What am I missing?

  • Jakub Vrána

    Jakub Vrána - 2012-06-29

    It looks like that you didn't fill the server name.

  • Nobody/Anonymous

    I did fill in the server name.  I just removed it for the post to be generic.  I also tried the ip address of the server, same result.

  • Nobody/Anonymous

    I shut down both firewalls, on the client machine, and on the server still same result.  Nothing is showing up in any of the logs in /var/log/mysql or /var/log/messages or /var/log/syslog.

  • Nobody/Anonymous

    I found it, it was the permissions on the root account in mysql.


  • Nobody/Anonymous

    By the way, I forgot to mention.  This is a great script.  It feels good to get away from phpmyadmin. Thanks!



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks