$100 bounty for help getting ssl working

Help
2009-06-12
2013-05-20
  • Josh Copeland

    Josh Copeland - 2009-06-12

    My team is building a company intranet system and we have implemented the adLDAP class for authentication and now we want to be able to add new users/update passwords/setup exchange mailboxes/etc...

    We have the class working for authentication but we cannot get SSL to work and our project time line is running out.

    We are running Mandriva 2009 with apache 2.0.54 and php 5

    We will make payment via paypal only.  1/2 will be paid on acceptance and the other once the class and SSL is working to our satisfaction.

    Please contact me at  jcopeland@cskhotels.com

    We need need this job finished by the weekend.

    Thanks,

     
    • Richard

      Richard - 2009-06-12

      Have you installed a the certificate on your domain controller?

      I'd recommend thoughly reading http://adldap.sourceforge.net/wiki/doku.php?id=ldap_over_ssl

      I wrote the documenation on installing both the standalone certificate authority and enterprise certificate authority walkthrough from performing both types of installations on domain controllers.

      After following those processes I successfully enabled connections over both SSL (LDAPs) and TLS.

      If you are forest level in AD then you can probably install the Enterprise CA but if not then a Standalone CA will work just as fine, it's just slightly harder to install, but so long as you use the .vbs script to create your requests then all should work fine.

       
    • Josh Copeland

      Josh Copeland - 2009-06-12

      I can test using ldp.exe on port 636 and get a successfull connection to the ldaps server.  Windows 2008 server.

      I am pretty sure the cert is installed correctly.  Exchange is working.

       
    • Josh Copeland

      Josh Copeland - 2009-06-12

      We think the actual issue is with openldap not windows or ssl

      when trying an ldapsearch we get the following error

      ldap_sasl_interactive_bind_s local error 2

      it is odd that we cannot find a slapd.conf file and I am not totally sure that we have the ldap.conf file configured correctly and in the correct location

      apache root is /etc/httpd

       
    • Josh Copeland

      Josh Copeland - 2009-06-16

      This is now Fixed.  It was a FQDN problem

       

Log in to post a comment.