Payroll Process Error

jmk
2011-02-09
2013-03-07
  • jmk

    jmk - 2011-02-09

    I'm relatively new to ADempiere and was especially thrilled to discover HR's been integrated into ADempiere 3.6.0LTS. However when I got to Payroll Process window and tried competing it, I got the error message below. Will appreciate it immensely if someone can help solve this.

    org.adempiere.exceptions.DBException: org.postgresql.util.PSQLException:
          ERROR: column "isregistered" does not exist

          Position: 52

     
  • Qaiser Zaman

    Qaiser Zaman - 2011-02-22

    Yes I'm also having the same problem, even the online demo available at testadempiere.com also have the same issue.

     
  • Qaiser Zaman

    Qaiser Zaman - 2011-02-22

    after peeking through source I've found a reference to isregistered column in hr_concept table, but database had it missing even after creating the column and syncing with dictionary same problem.

     
  • Qaiser Zaman

    Qaiser Zaman - 2011-02-22

    just updated with latest patches; the error is gone, will check the process and post feedback.

     
  • Jonas Magnusson

    Jonas Magnusson - 2011-03-23

    Which patches did you apply? I believe I have the latest patches and am experiencing the same error.

     
  • Herman

    Herman - 2011-04-27

    I have the same problem, I downloaded the patch recommended by John Agudelo.
    I applied the migration script sql using pgAdmin, first it gave me an error, after some research I found that I need to add "SEARCH_PATH TO adempiere" and that seems to let me execute the sql.
    Then I followed the steps to copy the .jar and finally RUN_silentsetup.bat, but it gave an error message "java.io.Exception: Keystore was tampered with, or password was incorrect".
    Any idea why ?

    Thanks

     

Log in to post a comment.