SourceForge has been redesigned. Learn more.
Close

On Order Qty shows qty on PO without any SO

Jahn Andy
2012-02-17
2013-09-05
  • Jahn Andy

    Jahn Andy - 2012-02-17

    Hello,

    I have this problem. I created PO and entered qty to order then saved it.  No sales order was created for this item.
    But when I wanted to delete the line item later it threw an error: Could not delete record: Reserved Quantity = 17000
    How else might I have gotten this number on my PO's On  Order Quantity Field?
    Is there any way to delete this line or PO?

    Thank you for your help.

    Jahn

     
  • Trifon (An ADempiere founder)

    Hi Jahn,

    I suppose you have completed this Purchase Order, right?

    If your Purchase Rrder is completed then you can't delete it because it creates Reservation record. This is the reason why you see the error message.

    Plesae describe the steps you have made?

    Best regards,
    Trifon

     
  • Jahn Andy

    Jahn Andy - 2012-02-19

    Hi Trifon,

    Document status is In Progress, it was never completed. The problem is I created this draft some time ago and can't recall the exact steps I performed. I only realized this when I tried to delete the line item.
    I added additional lines and they didn't trigger reservation. Maybe I should reset the reservation in the database directly to delete this record?  Which table would I temper with?

    Thank you Trifon.

    Jahn

     
  • Jahn Andy

    Jahn Andy - 2012-02-19

    Trifon,

    I was able to delete this record in the database. Problem solved.

    Thank you.
    Jahn

     
  • goran djermanovic

    How did you delete reservation? I have similar problem, I have some reservation made because of wrong MO. I have set MO quantities to 0 and delete MO but reserved quantities are still there and I don't now how to delete it or reset, can somebody help?

     

Log in to post a comment.