Report is blank when based on db view

  • Michael Stegall

    Michael Stegall - 2012-09-08

    Hello everyone,
    I'm having trouble with a report made in Adempiere. I've made many reports before but this one doesn't seem to work. This report is using a view made in the database. I also created the view in adempiere with the table and field window. I then created the columns from db, I got the message showing the columns were imported correctly.

    I made a report and report view with the view set as table. I created the menu item and did a cache reset and then logged in as normal user and ran the report and it's blank. I have many other reports built the exact same way with views and they work just fine. All the columns are in the print format screen on the sort order, display order, and format item tabs yet no data is shown.

    The query/view is correct because I tested it before making the view and got the desired information. I then did a select * from the view and got the same data so the view is not the problem. The view in the db is named rv_deskmonth and I named it the same when importing the view into adempiere. I tried this yesterday and got the same result. I vacuumed the db and tried again with no luck so I dropped the db and restored it with a daily backup and tried to create this report again but experienced the same problem.

    What is going on?!!!!!

    P.S. I tried checking and unchecking the "view" checkbox in the table and field window but still no luck.

  • Colin Rooney

    Colin Rooney - 2012-09-09

    Maybe… check the security for the take and ensure the role you use has access.


  • Michael Stegall

    Michael Stegall - 2012-09-11

    Maybe… check the security for the take and ensure the role you use has access.


    I checked to make sure my role has access and did a role access update to be sure.  My user is in the admin group and the report was made as Super User

  • Ricardo Santana

    Ricardo Santana - 2012-09-11

    Hi ancr2001,

    Check the columns of your view in Adempiere (Table and Column window). You probably have some columns with a wrong Reference, like: Table Direct instead of Table or something like that.


  • Michel Rousseau

    Michel Rousseau - 2012-12-17


    Estou com dificuldades para gerar um relatório específico que necessite de algumas informações como CNPJ, por exemplo. A minha dificuldade, em verdade, está relacionado com a geração de uma view e onde referenciar a mesma. Você poderia nos ajudar?




Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks