Change Date Format Pattern

Help
Matt
2012-05-02
2013-03-08
  • Matt

    Matt - 2012-05-02

    Hi guys,

    My date fields in all my tabs have defaulted to the format "MM/dd/yyyy".

    I would like to have them as "dd/MM/yyyy", but I can't seem to get it to work.

    I tried changing individual format patterns in the table & column Window.

    I also tried changing the date format pattern in my system language, but that didn't work either.

    Any ideas guys? Is "dd/MM/yyyy" the correct value to put in the format pattern box of a column in a table?

     
  • AZZAM OTHMAN

    AZZAM OTHMAN - 2012-05-02

    Hi,

    In Language.java change the fitfth argumet to "dd/MM/yyyy" in the line "AD_Language_en_US …. "

    I hope this helps.

    Azzam

     
  • Colin Rooney

    Colin Rooney - 2012-05-02

    By "System Language" do you mean of your computer?  That is not necessary.
    When you login to Adempiere one of the options you select is the Language.  You need to set the date format for this Language in Adempiere.  You can change this when you login with the System Admin role.

    If this is what you are changing and the change is not occurring then try resetting the cache. Search the menus for this process.

    colin

     
  • Matt

    Matt - 2012-05-06

    @Azzam
    As much as I would like to, I cannot change the Adempiere source code. Can only work from the front-end.

    @Colin
    Sorry I wasn't very clear. I meant System Language within Adempiere, just as you mentioned (via System admin role).
    OK I will try resetting the cache and see how it goes.

     
  • Matt

    Matt - 2012-05-06

    I didn't have to reset the cache, but after leaving it for a couple of days, the System Language seems to have done the trick.

    Thanks for your help guys :)

     

Log in to post a comment.