I have struggled to get adempiere 370 installed and configured.
I am running postgresql 8.4 and JDK 188.8.131.52
When i run the adempiere client i get the following error
Java hotspot client vm 1.7.0_01 <> 1.5.0
Please can someone help
At a guess David, you have different versions of java on the server and client!?
pls use jdk6! ADempiere 3.7.0 need jdk 1.6.0….
Currently only support Java 5 and 6 for ADempiere 3.7.0 , we will support Java 7 to next release
Hello All. Is there anyone who has solved this issue? Please tell me how to reslove it. I'm using jdk1.6
I unzipped the ADempiere source and went to adempiere/base/src/org/compiere/util/Login.java near line 104, and added an "if" statement to accept "1.7.0", as well as "1.6.0" and "1.5.0" (actually, I made it simply accept "1" in a hurry). Then followed the ADempiere documentation to recompile and install it. SInce I am not a contributor, yet, it is not official, so you will have to do the same thing yourself.
I also faced this issue in Windows and I found that the cause is the Adempiere.exe was built using launch4j. Unfortunately, launch4j's EXE ignores JAVA_HOME setting and always uses newest installed JRE.
So the solution (in windows) is to run: ADEMPIERE_HOME\utils\RUN_Adempiere.bat
Sign up for the SourceForge newsletter:
You seem to have CSS turned off.
Please don't fill out this field.