Adempiere Client not working

2011-11-30
2013-03-08
  • David Langley

    David Langley - 2011-11-30

    Hi

    I have struggled to get adempiere 370 installed and configured.
    I am running postgresql 8.4 and JDK 1.5.0.19

    When i run the adempiere client i get the following error

    Java hotspot client vm 1.7.0_01 <> 1.5.0

    Please can someone help
    Many Thanks

     
  • Colin Rooney

    Colin Rooney - 2011-11-30

    At a guess David, you have different versions of java on the server and client!?

    colin

     
  • RAM

    RAM - 2011-11-30

    Hi David,

    pls use jdk6! ADempiere 3.7.0 need jdk 1.6.0….

    Regards,
    Raouf

     
  • Victor Perez Juarez

    Hi David,!

    Currently  only support Java 5 and 6 for ADempiere 3.7.0 , we will support Java 7 to next release

    kind regards
    Víctor Pérez

     
  • Syed Muhammad Ali Naqvi

    Hello All. Is there anyone who has solved this issue? Please tell me how to reslove it. I'm using jdk1.6

     
  • Bruce Patin

    Bruce Patin - 2012-08-17

    I unzipped the ADempiere source and went to adempiere/base/src/org/compiere/util/Login.java near line 104, and added an "if" statement to accept "1.7.0", as well as "1.6.0" and "1.5.0" (actually, I made it simply accept "1" in a hurry).  Then followed the ADempiere documentation to recompile and install it.  SInce I am not a contributor, yet, it is not official, so you will have to do the same thing yourself.

     
  • Anonymous - 2012-11-13

    Hi,

    I also faced this issue in Windows and I found that the cause is the Adempiere.exe was built using launch4j. Unfortunately, launch4j's EXE ignores JAVA_HOME setting and always uses newest installed JRE.

    So the solution (in windows) is to run: ADEMPIERE_HOME\utils\RUN_Adempiere.bat

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks