insmod segfault + OOPS

  • Jakub Lacki

    Jakub Lacki - 2004-09-30

    I've tried to load the new pf33 version but the insmod command crashed (Segmentation Fault) and the driver caused an oops. it crashed when it tried to memcpy the firmware loaded from a file. the same happened when I used an older pf version, but pre8 works fine for me. I use the newest firmware.

    The pre8 driver was working perfectly well for many months, but now it looses connection after few minutes. the logs are full of "Processing deauthen packet. Should this have happened?" and "Sending deauthen packet...". is it possible that this error is caused by very poor connection quality?

    • Jakub Lacki

      Jakub Lacki - 2004-10-01

      I made a mistake, the logs are full of "Processing deauthen packet. Should this have happened?", "Sending authenticate packet..." and "WEP might not be working in ad-hoc mode yet". I'm sorry, but the computer wchich has the acx100 card has no internet connection as long as the WLAN is not working, so I don't have the logs.

    • Jakub Lacki

      Jakub Lacki - 2004-10-02

      I've solved some of my problems. The pf33 drivers work if I use the 2.6.X kernel. The connection is, hovewer, still not working. It seems that an antenna is broken.

      • Andreas Mohr

        Andreas Mohr - 2004-10-03

        Hmm? I STRONGLY doubt that.
        There are bazillions of reasons other than hardware damage why a connection might not work.
        Did you try iwpriv SetRates (README!) to test other basic/operational rates?
        I suspect that in most cases of strange Deauthen storms the router doesn't like some packet attributes of our driver. Try fiddling with rates, preamble, ...
        A firmware update of the router also helped sometimes.
        Good luck!

        Which 2.4.x kernel was it that crashed on firmware upload? Does it happen with a specific firmware only?
        I'd like to get that fixed if possible...


        Apart from that I'm happy to report that I'm currently doing long-time stability testing of the connection, and I already managed to improve several things again :-)

        This chipset IS problematic here, but it's not too astonishing when you're crammed into a notebook with horrible environment conditions next to an "almost melting" CPU and graphics card ;-)

    • Jakub Lacki

      Jakub Lacki - 2004-10-03

      You were right :). I've changed the channel to 6 and everything started working again. There was another network on channel 1 that interfered with mine in some strange way.

      I've just tried to crash the driver once again, when I realised that I tried to use the module compiled for i686 on an i586... sorry for misinformation


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks