dlink dwl-520g+ & gentoo

Anonymous
2008-10-25
2013-02-17
  • Anonymous - 2008-10-25

    First of all let me thank you for the driver:)
    I'm very new to this wireless stuff on linux, today i've tried to set it up and haven't succeeded so far.
    I want my gentoo comp to be wifi provider for a notebook.

    The comp's athlon 64 dual-core with gentoo 2.6.24-r8, the card is dlink dwl-520g+.
    Notebook is asus f7z with vista home premium, wireless inside is Atheros AR928x.

    I've grabbed acx portage ( 0.3.37_p20080112) and wireless-tools(v29). The former is masked for amd64 though.
    The driver has compiled with few warnings concerning 64-bitness, no problem to insmod.
    iwlist scan shows something's alive in the air around. So i think it's more or less ok.

    But stumbling around sometimes i see timeout problems in dmesg. Notebook doesn't feel anything happening.
    Grabbed what i could from download link (acx-20080210), no big change. Tried acx-mac, doesn't compile (exactly what peterdemaeyer has written). Not yet tried the latest git, is there any sense in it?

    Probably a misconfiguration?
    Does it suffice to
    iwconfig wlan0 essid test mode ad-hoc
    ifconfig wlan0 192.168.1.1 netmask 255.255.255.0
    to start it up?

     
    • David Planella

      David Planella - 2008-11-01

      Hi,

      Please try the recently committed version in our git repository. This has some fixes for compilation issues on 2.6.27 kernels, but it also fixes some minor issues with 64 bit systems and should compile fine on your 2.6.24 kernel.

      a) You can either download it using the direct link to a gzipped archive of the sources:

      http://tinyurl.com/5kblnd

      b) Or alternatively, assuming that git [1] is installed on your system, get the sources trough git, by typing the following on the command line:

        git clone git://gitorious.org/acx-mac80211/mainline.git
        cd mainline
        git checkout -b non-mac80211 origin/non-mac80211

      You can also browse this commit on the 'non-mac-80211' branch at http://gitorious.org/projects/acx-mac80211/repos/mainline/commits/66c159d3325d0dfe0b15b0cfaf4170e02bc881f5

      Note: this probably needs some testing before being released. Also, the usb part of the driver has not been tested at this point and might need some adjustments.

      Please test it and report back.

      [1] http://git.or.cz/

       

Log in to post a comment.