Error accesing Asterisk

Help
Anonymous
2009-10-19
2013-05-30

  • Anonymous
    2009-10-19

    I have ActivaTSP 1.4.8 installed on Windows 2003 server but it can't access to asterisk server: This is the log:

    10/19/09 12:26:38  TRACE  TSPI_providerEnumDevices()
    10/19/09 12:26:38  TRACE  Dn expression to filter: 6136,
    10/19/09 12:26:38  TRACE  Valid expression: 6136,
    10/19/09 12:26:38  TRACE  Total DN number = 1
    10/19/09 12:26:38  TRACE   DN = 6136
    10/19/09 12:26:38  TRACE  TSPI_providerInit()
    10/19/09 12:26:38  INFO   __________________ ASTProvider::Create __________________
    10/19/09 12:26:38  INFO   *** ASTProvider::Create() ***
    10/19/09 12:26:38  INFO   __________________ ASTCstaProvider::Create __________________
    10/19/09 12:26:38  INFO        $Revision: 448 $
    10/19/09 12:26:38  INFO   _____________________________________________________________
    10/19/09 12:26:38  INFO   __________________ ASTTapiProvider::Create __________________
    10/19/09 12:26:38  INFO   _  ActivaTSP.tsp vV1.4.8.1019 $Revision: 448 $                                  _
    10/19/09 12:26:38  INFO   _____________________________________________________________
    10/19/09 12:26:38  TRACE  TSPI_lineGetDevCaps() dwDeviceIdBase=5 dwDeviceID=5
    10/19/09 12:26:38  TRACE  TSPI_lineGetDevCaps() dwDeviceIdBase=5 dwDeviceID=5
    10/19/09 12:26:44  TRACE  TSPI_providerShutdown()
    10/19/09 12:26:44  TRACE  TSPI_providerShutdown()
    10/19/09 12:26:44  TRACE   CallMapCleanup() cleaning maps
    10/19/09 12:26:44  TRACE   CallMapCleanup() cleaning maps

     
  • activatsp
    activatsp
    2009-10-19

    Hi,

    I think there is enough information in this log, ActivaTSP don't tries to open the socket with Asterisk, unless I'm mistaken the first lineOpen is required to open the socket.

    What are you trying to do? What TAPI client use?

     
  • Mike Kelly
    Mike Kelly
    2011-11-15

    I am getting the same thing. It just does not try to connect.

    11/15/11 16:31:58 [860] TRACE [TSP] TSPI_providerShutdown()
    11/15/11 16:31:58 [860] TRACE [TAPIProvider] TSPI_providerShutdown()
    11/15/11 16:31:58 [860] TRACE [TAPIProvider]  CallMapCleanup() cleaning maps
    11/15/11 16:31:58 [860] TRACE [TAPIProvider]  CallMapCleanup() cleaning maps
    11/15/11 16:32:10 [1620] TRACE [TSP] TSPI_providerEnumDevices()
    11/15/11 16:32:10 [1620] TRACE [TSP ProcessDnExp] Dn expression to filter: 5046,
    11/15/11 16:32:10 [1620] TRACE [TSP ProcessDnExp] Valid expression: 5046
    11/15/11 16:32:10 [1620] TRACE [TSP ProcessDnExp] Total DN number = 1
    11/15/11 16:32:10 [1620] TRACE [TSP ProcessDnExp]  DN = 5046
    11/15/11 16:32:10 [1620] TRACE [TSP] TSPI_providerInit()
    11/15/11 16:32:10 [1620] INFO  [ASTProvider] __________________ ASTProvider::Create __________________
    11/15/11 16:32:10 [1620] INFO  [ASTProvider] *** ASTProvider::Create() ***
    11/15/11 16:32:10 [1620] INFO  [ASTCstaProvider] __________________ ASTCstaProvider::Create __________________
    11/15/11 16:32:10 [1620] INFO  [ASTCstaProvider]      $Revision: 554 $ 
    11/15/11 16:32:10 [1620] INFO  [ASTCstaProvider] _____________________________________________________________
    11/15/11 16:32:10 [1620] INFO  [TAPIProvider] __________________ ASTTapiProvider::Create __________________
    11/15/11 16:32:10 [1620] INFO  [TAPIProvider] _  ActivaTSP.tsp vV1.8.2.1042 $Revision: 554 $                                  _
    11/15/11 16:32:10 [1620] INFO  [TAPIProvider] _____________________________________________________________
    11/15/11 16:32:18 [1620] TRACE [TAPIProvider] TSPI_lineGetDevCaps() dwDeviceIdBase=0x6 dwDeviceID=0x6