#6 acpid-1.0.4-r1 build fails with gcc-4.0.0

closed
nobody
None
5
2005-08-19
2005-04-25
No

I tried build acpid-1.0.4-r1 with gcc-4.0.0 via emerge
on a Gentoo system. It seems that the greater
strictness of gcc-4.0.0 affects acpid:

cc -Wall -Werror -g -DVERSION="\"1.0.4\"" -c -o
ud_socket.o ud_socket.c
cc1: warnings being treated as errors
ud_socket.c: In function 'ud_accept':
ud_socket.c:63: warning: pointer targets in passing
argument 3 of 'accept' differ in signedness
ud_socket.c:74: warning: pointer targets in passing
argument 5 of 'getsockopt' differ in signedness
make: *** [ud_socket.o] Error 1

Discussion

  • Tim Hockin

    Tim Hockin - 2005-08-19

    Logged In: YES
    user_id=365227

    Noted. Fixed in CVS. Thanks.

     
  • Tim Hockin

    Tim Hockin - 2005-08-19
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks