Audio / Video sync

Help
gnuhitch
2004-11-08
2013-04-25
  • gnuhitch

    gnuhitch - 2004-11-08

    I'm thrilled with Acidrip, the ease of use and the quality of the output is super.  Except my audio is about slightly behind the video, only about .5-1 second, but I notice it.  Any ideas on how I can fix that?

    thanks

     
    • Nobody/Anonymous

      this a bug in mplayer which the mplayer developers kindly refuse to acknowledge exists. Each time i, or anyone else afaik, attempts to raise the fact that there is frequently a 200ms delay in the audio, they try to pin it on dodgy sound drivers.

      it's posibly to use the -af delay filter to move the sound later on purpose, but not the other direction,

      sorry.....

       
    • Nobody/Anonymous

      Hello, very good program, easy to use, I like :)

      I had too the problem with audio / video sync but with some tracks of a DVD, not all. And after a quickly test under Windows XP ( :-D I know, I know....), It appear there is no desynchronisation with audio.

      So.... Mplayer's Dev have a strange attitude.... ! Don't understand why they would not correct this... We run under Linux, not under Windows :(

       
    • Jeff Carr

      Jeff Carr - 2005-04-24

      Yes, I always see this on xine playback. (hit m to about .32 makes it perfect).

      I've tried a zillion things over time to try to repair this. most  notably by converting the final .avi file to a .ogm file. In the process, I convert the audio stream into a wav file, cut a bit off the front, normalize the audio, then compress it with oggenc and merge the streams back into a .ogm file. This works fairly well but that is annoying. Maybe it's just the only way. Anyway, ogg media file format is superior anyway.

       
    • Jeff Carr

      Jeff Carr - 2005-04-24

      here is a script to do that post processing to a .ogm format:

      mplayer "$1.avi" -vc dummy -vo null -ao pcm -waveheader -aofile outfile.wav
      # hardcode the aplitude or gain if it is still too quiet
      # normalize-audio -vvv --amplitude=-15dbFS outfile.wav
      # normalize-audio -vvv --gain=15dB outfile.wav
      normalize-audio -vvv outfile.wav
      sox outfile.wav test.wav trim 10 30
      oggenc -q 6 outfile.wav
      ogmmerge -o "$1.ogm" -A "$1.avi" outfile.ogg
      rm -f outfile.*

       
    • seddah

      seddah - 2005-05-23

      the problem of ogm is that it won't play at all on any dvd/divx player.......
      It seems to me that the only solution I've found was to
      to manually set the delay (using the - and + key)
      but it didn't happen so often...

      most of the time using autosync and framedrop and the sound is fine......

       
    • Jeff Carr

      Jeff Carr - 2005-05-27

      The other option seems to be to add "-ofps 23.976" to the mencoder line. That might clear up the audio/video sync problem.

       
    • Michael

      Michael - 2005-05-28

      I found a fix for this... encoding using lavc audio instead pf mp3lib. Works the treat :)

       
    • Nobody/Anonymous

      If this is the case then perhaps the problem does not lie with mplayer?

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks