Problem in displaying ABP help from KeyPass

  • TemplerMan

    TemplerMan - 2011-07-06

    I am new to Discussions so bear with me!!
    I have just installed KeePass 1.20.  I have used ABP for some  time with 1.19b.  I think what I am about to report probably pertained with 1.19b but I did not take the time to chase it up!  Anyway, if I go to tools in 1.20 and select Help for another Backup Plugin, I get the following display:

    A screen which looks like a Help Home page with a Contents list down the left side but in the body of the screen a message saying, Navigation to the webpage was cancelled.

    I have extracted the following from hte screen.  May be of some help??

  • Bill Rubin

    Bill Rubin - 2011-07-06

    I cannot replicate this problem with either 1.19b or 1.20.  It works fine for me. 

    The Help window uses Internet Explorer (IE) settings, regardless of your default web browser.  I suspect that you may have some very conservative security settings for IE, and that this is causing your problem.  I also suspect that you should be seeing the same problem with KeePass Help (F1 or Help menu and select Help Contents).  Please post if that is not the case.

    Bill Rubin

  • TemplerMan

    TemplerMan - 2011-07-18

    Sorry for the delay in coming back on this.  I have now selected Monitoring to keep up with it!  I will check my IE setting as you suggest.  I use Firefox 5.0 as my default browser.  I am on Windows 7 Home Premium Service Pack 1

    I have just checked the KeyPass Help and it displays OK

  • Bill Rubin

    Bill Rubin - 2011-07-18

    Try this:  In Windows Explorer, right click on AnotherBackupPlugin.chm (in your C:\Program Files\KeePass Password Safe folder) and select Properties.  Then select Unblock.  Please post to let me know if this worked.

    Bill Rubin

  • TemplerMan

    TemplerMan - 2011-07-18

    Hi Bill …  Its working OK.  Not sure what action did the trick in the end!  I did as you suggested.  The properties showed a message to the effect that the file came from another computer and might be blocked for security reasons.  I clicked the "Unblock" button and clicked "Apply" and closed the box.  I went to try the help option (KeyPass was already active and in the system tray) and the system came up asking if I wanted to Open the file (it had not done this before so I was in hope) to which I said Yes.   Outcome was not OK  ..same as before.  I went back to the properties again and was surprised that the option to Unblock was still there.  (Not sure now of the exact sequence I then followed!!)  I think I unblocked, closed and opened the properties again to find that nothing had changed.  I then went to the security settings on the file and changed the All Users to allow all options and I decided to shut down and restart KeyPass and now ABP worked OK.  I went back and looked at properties again and the Unblock option no longer appeared at all.  I changed the security setting on All Users to the original settings, closed and restarted KeyPass and all was still OK.

    So many thanks

    Ian Hobday

  • Bill Rubin

    Bill Rubin - 2011-07-19

    Thanks for your detailed post.  I'm so glad this worked for you.  I think it's the Unblock that did the trick.  By the way, my documentation for Installing and Configuring ABP describes this problem and various solutions.  See

    Windows Security Warning

    in the section

    How to Install ABP


    Bill Rubin


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks