Unable to build SDK 1.1.4 DR1 on OSX 10.6

Developers
2010-11-28
2013-04-29
  • Sebastian Morsch

    Hi,

    I've tried in vain to build ('make everything') the downloaded SDK under OSX 10.6.5 Snow Leopard. I get numerous warnings from ld about the 64 bit architecture, for example:

    ld: warning: in ../../../AAFi386DarwinSDK/g++/lib/debug/libaaflib.a, file was built for unsupported file format which is not the architecture being linked (x86_64)

    and the build eventually fails with

    Undefined symbols:
      "_main", referenced from:
          start in crt1.10.6.o
    ld: symbol(s) not found
    collect2: ld returned 1 exit status
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2
    make: ***  Error 2

    Do I have to modify the build process somehow to make it work? I should mention that I'm quite the make-noob, so my apologies if this is a trivial question!

    Thanks!
    Sebastian

     
  • Anonymous

    Anonymous - 2011-06-14

    I read somewhere in the readme files that on OS X only 32bit builds are possible.

     
  • Lian Zhang

    Lian Zhang - 2011-06-15

    The same problem I met on the Windows 7. I think we all need 64bit SDK to build successful.

    I am also concerning when 64bit version will release. I tried to use updated one to build but it's still failed.

    The problem is "ssrw_c.lib" within the SDK is 32bit as well. Could admin please provide a new 64bit ssrw_c.lib to us?

    Cheers,
    Lian

     

Log in to post a comment.