Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.
Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
Start Free
$300 Free Credits to Build on Google Cloud
New customers can spin up VMs, build with AI, and query data at no cost.
Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
An easy-to-use generator for large numbers of passwords.
Originally for my school's IT Department, I have now released the source code under the GNU GPL. It supports the random generation of huge numbers of passwords that can be determined in a variety of ways.
This project consists of a proxy application that supports SMTP and POP3 and archives those emails in rfc 822 format. It does not include any archive but uses existing archives through a plugin infrastructure.
JSysmon is a Java library providing access to system information like CPU or Memory usage on various platforms using native calls. It can be used to build cross-platform monitors in your applications.
Java Password Tracker. A cross-platform application to safely store away your passwords. The file format is compatible with the original password safe application.
RemoteSocket Java API and implementation for local/remote infrastructure.
This API allow to create a client Socket and ServerSocket on remote machine and manipulate with such socket as it on local machine.
IPv6SubnetCalc is a comprehensive calculator for IPv6 addresses. It comes with Java Swing GUI and supports the following RFCs: RFC4291, RFC4193, RFC3849, RFC2464, RFC5375, RFC4941, RFC3513, RFC3879, RFC4941, RFC3056, RFC3587, RFC2374, RFC3306, RFC3956.
Archive files by date. Scans the folders, and archive them by dates. Features: 1. Simulation -- allows user to see what will happen before it commits 2. Progress bar -- a separate thread running a progress bar.
Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.
Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
MelaJò Portal Framework is a framework to develop Java Enterprise/J2EE/MVC based applications rapidly and easily.
It's based on Finite State Machine concept. It's used for years
to create real business web applications with J2EE architecture.
Communication program that allows one instance to act as a server and then any number of instances to connect through any desired port (specified by the server) to Chat and transfer Files, the server relaying. Chat history can also be saved.
Acelet-Scheduler with SuperScheduler and SuperWatchdog is a Java task scheduler with daemon and GUI for system and application job scheduling, can schedule tasks in a distributed environment. Holiday adjustable. Works out-box. See http://www.acelet.com
GES tool is the result of integrating the Google Desktop Search (GDS) engine into IBM’s Eclipse development environment to improve searching in software projects in a manner similar to searching the internet or your own desktop.
Configuration managment utility enables a Java application to read and manage configuration data from a variety of sources: property files, XML, database, JNDI, Log4J. Web client provided. JMX enabled.
MD5 Rescue permite reparar archivos que se han corrompido si se dispone de como mínimo dos archivos corrompidos (corrompidos en diferentes partes) y se conoce el md5 del archivo correcto.
A Java library that simplifies thread development. It has support for continuations, fork/merge, signals, thread and process serialization, event picker (similar to BPEL's pick element), among other features.
BlueCove is a JSR-82 implementation on Java Standard Edition (J2SE) on BlueZ Linux, Mac OS X, WIDCOMM, BlueSoleil and Microsoft Bluetooth stack on WinXPsp2 and newer. Originally developed by Intel Research and currently maintained by volunteers.
The Weblog Downloader allows users to download and archive their weblog entries in their local drives. Includes login functions to download "private" posts, option to download images, and Java GUI. Currently implemented for Xanga weblog entries.
This is a tiny JMX agent for ZFS. It relies on the presence of the commands "zpool" and "zfs". It defines two MBean types, one for pools and another for datasets. This agent can provide ZFS-specific monitoring for management tools that support JM
Nessconnect is a GUI, CLI and API client for Nessus and Nessus compatible servers. With an improved user interface, it provides local session management, scan templates, report generation through XSLT, charts and graphs, and vulnerability trending.
This is a simple Java front-end for the UNIX grep. It lets you search file contents also if you are not familiar with the command line or the regular expression syntax.