Showing 18 open source projects for "web servers"

View related business solutions
  • $300 Free Credits to Build on Google Cloud Icon
    $300 Free Credits to Build on Google Cloud

    New customers can spin up VMs, build with AI, and query data at no cost.

    Put your $300 in credit toward real workloads, then keep building with free monthly usage for 20+ products. No commitment and no charge until you upgrade.
    Start Free
  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • 1
    ciao

    ciao

    HTTP checks & tests (private & public) monitoring

    HTTP checks & tests (private & public) monitoring - check the status of your URL. ciao checks HTTP(S) URL endpoints for a HTTP status code (or errors on the lower TCP stack) and sends a notification on status change via E-Mail or Webhooks. It uses Cron syntax to schedule the checks and comes along with a Web UI and a RESTful JSON API. Create an open-source web application for checking URL statuses with a UI and a REST API which is easy to install and maintain (no external dependencies like...
    Downloads: 9 This Week
    Last Update:
    See Project
  • 2
    LibreSpeed

    LibreSpeed

    Self-hosted Speedtest for HTML5 and more

    Self-hosted Speedtest for HTML5 and more. Easy setup, examples, configurable, mobile friendly. Supports PHP, Node, Multiple servers, and more. This is a very lightweight Speedtest implemented in Javascript, using XMLHttpRequest and Web Workers. All modern browsers are supported: IE11, latest Edge, latest Chrome, latest Firefox, latest Safari. Works with mobile versions too. Requires a reasonably fast web server with Apache 2 (nginx, IIS also supported) PHP 5.4 (other backends also available) MySQL database to store test results (optional, PostgreSQL and SQLite also supported) A fast! ...
    Downloads: 11 This Week
    Last Update:
    See Project
  • 3
    Fronsetia

    Fronsetia

    A web application for testing webservices

    Fronsetia (Free Online Service Testing Application) is a Java web application that allows testing webservices (REST and SOAP). No end-user installations required, just deploy the application on your server and pass the link so that users can use their usual browsers to access Fronsetia. You can think of Fronsetia as a simple version of SoapUI on the web, or a simple and free and open-source version of the "wls_utc" utility. See the project homepage https://fronsetia.sourceforge.io and...
    Downloads: 1 This Week
    Last Update:
    See Project
  • 4
    Apache JMeter

    Apache JMeter

    Load testing tool for analyzing and measuring performance of services

    The Apache JMeter™ application is open-source software, a 100% pure Java application designed to load test functional behavior and measure performance. It was originally designed for testing Web Applications but has since expanded to other test functions. Apache JMeter may be used to test performance both on static and dynamic resources, Web dynamic applications. It can be used to simulate a heavy load on a server, group of servers, network or object to test its strength or to analyze overall performance under different load types.
    Downloads: 45 This Week
    Last Update:
    See Project
  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • 5
    MailHog

    MailHog

    Web and API based SMTP testing

    ...The SMTP server starts on port 1025, the HTTP server starts on port 8025, in-memory message storage. ESMTP server implementing RFC5321. Support for SMTP AUTH (RFC4954) and PIPELINING (RFC2920). Web interface to view messages (plain text, HTML or source). Supports RFC2047 encoded headers. Real-time updates using EventSource. Release messages to real SMTP servers. Chaos Monkey for failure testing. HTTP API to list, retrieve and delete messages. See APIv1 and APIv2 documentation for more information. HTTP basic authentication for MailHog UI and API. ...
    Downloads: 24 This Week
    Last Update:
    See Project
  • 6
    HTTP Test Tool
    httest is a script based tool for testing and benchmarking web applications, web servers, proxy servers and web browsers. httest can emulate clients and servers in the same test script, very useful for testing proxys.
    Downloads: 3 This Week
    Last Update:
    See Project
  • 7
    FoxNuke

    FoxNuke

    A Proffesional Stress-Testing(ddos) tool for pentesters

    The FoxNuke program is written in python and uses Firefox in order to complete the distributed denial of service attack feature. Multiple headers are used from the Firefox browser, along with a personal configuration option for the Opera browser. The FoxNuke Program is still underdevelopment as of 8/24/17, full release is set to come out sometime during 2017-2018. If you would like to participate in the TESTING of this program and would like to help report bugs, etc. then please email...
    Downloads: 0 This Week
    Last Update:
    See Project
  • 8
    SoaBox
    SoaBox lets you create a virtual version of your SOA environment. Clients (WS-Webservices,RESTful, JMS, HTTP, FTP, Filesystem, POJOs/Custom Code), servers (HTTP/Endpoints) and data (XML, SOAP, CSV, etc). It's written in Java and runs with JBoss 5.x and 6.x
    Downloads: 0 This Week
    Last Update:
    See Project
  • 9
    nGrinder

    nGrinder

    Enterprise level performance test platform on The Grinder

    nGrinder is a platform for stress tests that enables you to create test scripts, execute tests, monitor servers, and generate results simultaneously on the power of The Grinder. The open-source nGrinder offers easy ways to conduct stress tests by eliminating inconveniences and providing integrated environments. Our company NHN uses nGrinder to test several projects. Some have more than 100 million users.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Go from Code to Production URL in Seconds Icon
    Go from Code to Production URL in Seconds

    Cloud Run deploys apps in any language instantly. Scales to zero. Pay only when code runs.

    Skip the Kubernetes configs. Cloud Run handles HTTPS, scaling, and infrastructure automatically. Two million requests free per month.
    Start Free
  • 10
    XML Mimic
    XML Mimic is a stub web server that can mock/simulate web XML responses and runs as independent HTTP server stub. Client apps that require real server for fetching xml/html responses can use this software during development and testing. Suitable for testing client application that requires any REST based web service, JSON,etc as replacement for web service server. Can also be used for any client that require HTTP based application response.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 11
    DirBuster
    DirBuster is a multi threaded java application designed to brute force directories and files names on web/application servers.
    Leader badge
    Downloads: 374 This Week
    Last Update:
    See Project
  • 12
    Jexin is a functional testing platform for Java applications. Jexin allows the user to dynamically inject exceptions based on the execution path taken. Users can record, compare, and merge stack traces for fault isolation across threads and servers.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 13
    CASIMIR is a web-based PHP/MySQL interface which controls over SSH-secured connexions qemu/kvm virtual machines dispatched over several physical servers. It also provides to administrators the ability to delegate control of these machines to other users.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 14
    Syncopate is an extension module to the Apache JMeter testing tool. It enhances JMeter's HTTP proxy server by adding functionality to extract variables and create assertions during HTTP request recording.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 15
    COMPAS J2EE is a non-intrusive performance instrumentation and monitoring toolkit for J2EE. It uses adaptive monitoring to automatically adjust the target coverage. COMPAS is completely portable across J2EE application servers and OSs.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 16
    Web based Defect tracking / Issue tracking application developed in Java and intended to run using variety of Database and Web/App servers
    Downloads: 0 This Week
    Last Update:
    See Project
  • 17
    This is a HTTP traffic generator for load testing web applications. It is very simple and fast and can simulate client activity on multiple servers at the same time. Supports almost all http methods such as GET, POST, HEAD
    Downloads: 0 This Week
    Last Update:
    See Project
  • 18
    OpenLC is a set tools designed to facilitate benchmarking and stress testing of a wide variety of information servers (WEB, Email, FTP, LDAP, ...). A XML-RPC API is offered for developers interested in creating clients that query the services provid
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next